Bug 524072 - dependency problems with gnome-bluetooth* from updates-testing
Summary: dependency problems with gnome-bluetooth* from updates-testing
Keywords:
Status: CLOSED DUPLICATE of bug 513807
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth
Version: 11
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 19:05 UTC by Stefan Jensen
Modified: 2009-09-21 10:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 10:02:06 UTC


Attachments (Terms of Use)

Description Stefan Jensen 2009-09-17 19:05:07 UTC
Description of problem:

Packages update failed because of dependency problems:

    gnome-bluetooth-2.27.8-2.fc11.x86_64 from updates-testing
    gnome-bluetooth-libs-2.27.8-2.fc11.x86_64 from updates-testing

How reproducible:

Always

Steps to Reproduce:

1. enable updates-testing repo
2. yum clean all
3. yum update
  
Actual results:

$ sudo LANG=C yum --skip-broken update

Loaded plugins: allowdowngrade, fastestmirror, presto, protectbase, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * fedora: ftp.crc.dk
 * livna: wftp.tu-chemnitz.de
 * rpmfusion-free: lnx.apollo-hw.ro
 * rpmfusion-free-updates: lnx.apollo-hw.ro
 * rpmfusion-free-updates-testing: lnx.apollo-hw.ro
 * rpmfusion-nonfree: lnx.apollo-hw.ro
 * rpmfusion-nonfree-updates: lnx.apollo-hw.ro
 * rpmfusion-nonfree-updates-testing: lnx.apollo-hw.ro
 * updates: ftp.crc.dk
 * updates-testing: ftp.crc.dk
0 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package gnome-bluetooth.x86_64 0:2.27.8-2.fc11 set to be updated
--> Processing Dependency: libgnome-bluetooth.so.2()(64bit) for package: gnome-phone-manager-0.65-1.fc11.x86_64
---> Package gnome-bluetooth-libs.x86_64 0:2.27.8-2.fc11 set to be updated
--> Finished Dependency Resolution
gnome-phone-manager-0.65-1.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libgnome-bluetooth.so.2()(64bit) is needed by package gnome-phone-manager-0.65-1.fc11.x86_64 (installed)
--> Running transaction check
--> Processing Dependency: gnome-bluetooth = 2.27.5-1.fc11 for package: gnome-bluetooth-libs-2.27.5-1.fc11.x86_64
---> Package gnome-bluetooth-libs.x86_64 0:2.27.8-2.fc11 set to be updated
--> Processing Dependency: libgnome-bluetooth.so.7()(64bit) for package: gnome-bluetooth-2.27.8-2.fc11.x86_64
--> Finished Dependency Resolution
gnome-bluetooth-2.27.8-2.fc11.x86_64 from updates-testing has depsolving problems
  --> Missing Dependency: libgnome-bluetooth.so.7()(64bit) is needed by package gnome-bluetooth-2.27.8-2.fc11.x86_64 (updates-testing)
gnome-bluetooth-libs-2.27.5-1.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: gnome-bluetooth = 2.27.5-1.fc11 is needed by package gnome-bluetooth-libs-2.27.5-1.fc11.x86_64 (installed)

Packages skipped because of dependency problems:
    gnome-bluetooth-2.27.8-2.fc11.x86_64 from updates-testing
    gnome-bluetooth-libs-2.27.8-2.fc11.x86_64 from updates-testing

Comment 1 Didier G 2009-09-19 23:47:34 UTC
Same problem in i586 :

--> Lancement de la transaction de test
---> Paquet gnome-bluetooth.i586 0:2.27.8-2.fc11 marqué pour être mis à jour 
--> Traitement de la dépendance : libgnome-bluetooth.so.2 pour le paquet : gnome-phone-manager-0.65-1.fc11.i586
---> Paquet gnome-bluetooth-libs.i586 0:2.27.8-2.fc11 marqué pour être mis à jour 
--> Résolution des dépendances terminée
gnome-phone-manager-0.65-1.fc11.i586 de installed a des problèmes de dépendances
  --> Dépendance manquante : libgnome-bluetooth.so.2 est requis par le paquet gnome-phone-manager-0.65-1.fc11.i586 (installed)
Erreur : Dépendance manquante : libgnome-bluetooth.so.2 est requis par le paquet gnome-phone-manager-0.65-1.fc11.i586 (installed)

Comment 2 Leszek Matok 2009-09-20 07:58:59 UTC
This was moved to updates and now all "normal" users (with gnome-phone-manager installed) can't install updates at all (I haven't seen --skip-broken in PackageKit UI).

Promoting to stable updates happened even though there was a comment about this dependency bug in Bodhi (making karma 0) and of course there was this bug in BZ.

Identical bug #513807 (Bastien's previous try with gnome-bluetooth 2.27.8 - same results, only not moved to stable) was closed as... not a bug? Bastien, aren't you supposed to fix things that you've broken in updates-testing? Especially before moving to stable updates?

Comment 3 David Sommerseth 2009-09-21 08:47:07 UTC
To be able to update gnome-bluetooth and gnome-bluetooth-libs (bug #523001), I had to uninstall gnome-phone-manager, due to dependencies to the older gnome-bluetooth-libs.

After having updated gnome-bluetooth and -libs, I tried to reinstall gnome-phone-manager.

$ sudo yum install gnome-phone-manager
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-phone-manager.x86_64 0:0.65-1.fc11 set to be updated
--> Processing Dependency: libgnome-bluetooth.so.2()(64bit) for package: gnome-phone-manager-0.65-1.fc11.x86_64
--> Finished Dependency Resolution
gnome-phone-manager-0.65-1.fc11.x86_64 from fedora has depsolving problems
  --> Missing Dependency: libgnome-bluetooth.so.2()(64bit) is needed by package gnome-phone-manager-0.65-1.fc11.x86_64 (fedora)
Error: Missing Dependency: libgnome-bluetooth.so.2()(64bit) is needed by package gnome-phone-manager-0.65-1.fc11.x86_64 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Comment 4 Bastien Nocera 2009-09-21 10:02:06 UTC

*** This bug has been marked as a duplicate of bug 513807 ***


Note You need to log in before you can comment on or make changes to this bug.