Bug 524132 - No sound at all with Fedora 12 Alpha Live CD
Summary: No sound at all with Fedora 12 Alpha Live CD
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 01:50 UTC by Ilya Ryabinkin
Modified: 2009-09-29 04:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 04:35:35 UTC


Attachments (Terms of Use)

Description Ilya Ryabinkin 2009-09-18 01:50:29 UTC
Description of problem: No sound in Fedora 12 Alpha. Fedoras from 5 to 11 work fine. No system sounds, no sounds from youtube.


Version-Release number of selected component (if applicable): pulseaudio-0.9.16-5.test4.fc12.i686


How reproducible: Always


Steps to Reproduce:
1. Just boot from Fedora 12 Live CD
2.
3.
  
Actual results: No sounds


Expected results: Sound should work


Additional info: 
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
	Subsystem: Dell Latitude D610 Laptop
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03) (prog-if 00 [Generic])
	Subsystem: Conexant Systems, Inc. Device 5423

Comment 1 Lennart Poettering 2009-09-18 16:02:34 UTC
Does gnome-volume-control show a sound card?

Have you tried turning up the volume with gnome-volume-control?

Comment 2 Ilya Ryabinkin 2009-09-18 18:28:21 UTC
1. Yes

2. Yes, with no effect

Comment 3 Ilya Ryabinkin 2009-09-18 18:30:23 UTC
Someone reports, It works once user has has been added to 'audio' group, http://forums.fedoraforum.org/showpost.php?p=1259271&postcount=14

Comment 4 Lennart Poettering 2009-09-18 19:20:49 UTC
(In reply to comment #2)
> 1. Yes
> 
> 2. Yes, with no effect  

Hmm, that suggests that the low level mixer is not set up properly for some reason. Could you please play around with "alsamixer -c0" in a terminal and see if you can get it working? If you notice that toggling one control or changing the volume of another makes things work then please remember exactly which one and tell us, so that we can set them by default.

(In reply to comment #3)
> Someone reports, It works once user has has been added to 'audio' group,
> http://forums.fedoraforum.org/showpost.php?p=1259271&postcount=14  

That would suggest you have a permission problem and the card woldn't even show up in g-v-c. So since you said it shows up, this is not the problem here.

Comment 5 Ilya Ryabinkin 2009-09-18 19:27:38 UTC
(In reply to comment #3)
> Someone reports, It works once user has has been added to 'audio' group,
> http://forums.fedoraforum.org/showpost.php?p=1259271&postcount=14  

No, I cannot confirm. Sounds are not working.

Comment 6 Lennart Poettering 2009-09-18 20:51:52 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > Someone reports, It works once user has has been added to 'audio' group,
> > http://forums.fedoraforum.org/showpost.php?p=1259271&postcount=14  
> 
> No, I cannot confirm. Sounds are not working.  

Yes, I expressly wrote that this will unlikely fix the issue for you. 

What about the "alsamixer -c0" stuff I suggested above? And luck with that?

Comment 7 Ilya Ryabinkin 2009-09-19 14:03:31 UTC
alsamixer -c0 did not help. It recognized my card as
Card: Intel ICH6
│ Chip: SigmaTel STAC9750,51
│ View: [Playback] Capture  All

All channels are unmuted and set to non-zero values. Many combinations were tested in "Sound preferences". No luck. No sound at all.

Comment 8 Ilya Ryabinkin 2009-09-19 14:15:54 UTC
Updates:

Plugged headphones are working! But:
1. I hear a great background hum
2. pulsaudio daemon died after a few attempts to play sound with message:
  E: mainloop.c: Assertion 'e->callback' failed at pulse/mainloop.c:711, function dispatch_pollfds(). Aborting.
Aborted

Comment 9 Ilya Ryabinkin 2009-09-20 19:07:21 UTC
Sounds seem to work for me on Fedora 12 Snap3 http://torrent.fedoraproject.org/ (i686)

Comment 10 Lennart Poettering 2009-09-29 04:35:35 UTC
OK, closing then, since this seems to work now.

(Most likely this was just a missing model=xxx parameter to the intel-hda driver)


Note You need to log in before you can comment on or make changes to this bug.