Bug 524146 - unreasonable output of command 'ipsec --help' of openswan
Summary: unreasonable output of command 'ipsec --help' of openswan
Keywords:
Status: CLOSED DUPLICATE of bug 509318
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openswan
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Avesh Agarwal
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 06:18 UTC by Osier Yang
Modified: 2014-03-27 01:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-15 13:13:55 UTC


Attachments (Terms of Use)
Patch to fix the issue (638 bytes, patch)
2009-09-22 18:59 UTC, Avesh Agarwal
no flags Details | Diff

Description Osier Yang 2009-09-18 06:18:02 UTC
Description of problem:
the command list was listed twice when executing 'ipsec --help'

Version-Release number of selected component (if applicable):
openswan:    openswan-2.6.21-5.el5
OS            :     rhel5.4

How reproducible:


Steps to Reproduce:
1. $ ipsec --help
2.
3.
  
Actual results:
Usage: ipsec command argument ...
where command is one of:
        addconn
        auto
        barf
        eroute
        ikeping
        klipsdebug
        look
        newhostkey
        pf_key
        pluto
        ranbits
        rsasigkey
        secrets
        setup
        showdefaults
        showhostkey
        showpolicy
        spi
        spigrp
        tncfg
        verify
        whack
        addconn
        auto
        barf
        eroute
        ikeping
        klipsdebug
        look
        newhostkey
        pf_key
        pluto
        ranbits
        rsasigkey
        secrets
        setup
        showdefaults
        showhostkey
        showpolicy
        spi
        spigrp
        tncfg
        verify
        whack

Most of these have their own manual pages, e.g. ipsec_auto(8).
See also <http://www.freeswan.org> or the ipsec(8) manual page.


Expected results:
Usage: ipsec command argument ...
where command is one of:
        addconn
        auto
        barf
        eroute
        ikeping
        klipsdebug
        look
        newhostkey
        pf_key
        pluto
        ranbits
        rsasigkey
        secrets
        setup
        showdefaults
        showhostkey
        showpolicy
        spi
        spigrp
        tncfg
        verify
        whack

Most of these have their own manual pages, e.g. ipsec_auto(8).
See also <http://www.freeswan.org> or the ipsec(8) manual page.

Additional info:
have complied and installed openswan-2.6.23 from source code. the same unreasonable results.

Comment 1 Avesh Agarwal 2009-09-22 18:59:02 UTC
Created attachment 362129 [details]
Patch to fix the issue

I have added a patch for this, and will soon be sending to upstream.

Comment 2 Osier Yang 2009-09-23 02:44:18 UTC
it's great, I have reported a same bug on bugs.openswan.org, the bug link is: https://gsoc.xelerance.com/issues/1063,  may be you can attach the patch here. :)

Comment 3 Eduard Benes 2009-10-15 13:13:55 UTC

*** This bug has been marked as a duplicate of bug 509318 ***


Note You need to log in before you can comment on or make changes to this bug.