Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 524194 - Bind is performing forward lookups using IPv6 when no routable IPv6 address is assigned to the machine
Summary: Bind is performing forward lookups using IPv6 when no routable IPv6 address i...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 10:30 UTC by Colin.Simpson
Modified: 2013-03-12 14:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 14:33:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Colin.Simpson 2009-09-18 10:30:29 UTC
Description of problem:
I'm largely stealing this from a Fedora 11 bug #522999 cause now RH5.4 is behaving the same way.

BIND is sending forward lookup requests using IPv6 when no publicly routable
IPv6 address is assigned to the server.

Version-Release number of selected component (if applicable):
bind-utils-9.3.6-4.P1.el5
bind-9.3.6-4.P1.el5
bind-libs-9.3.6-4.P1.el5
  
Actual results:
Sep 17 16:15:07 nsserver named[21089]: network unreachable resolving 'ns2.vistaprint.com/A/IN': 2001:503:a83e::2:30#53
Sep 17 16:15:07 nsserver named[21089]: network unreachable resolving 'ns201.vistaprint.com/A/IN': 2001:503:a83e::2:30#53
Sep 17 16:15:07 nsserver named[21089]: network unreachable resolving 'ns2.vistaprint.com/AAAA/IN': 2001:503:a83e::2:30#53


Additional info:

This has only appeared in 5.4

Is this now the expected behaviour ? As in are we supposed to just put in OPTIONS="-4"" to /etc/sysconfig/named ?

Comment 1 Nils Breunese 2009-10-25 20:37:49 UTC
Adding -4 to OPTIONS in /etc/sysconfig/named is a workaround, but when NETWORKING_IPV6=no in /etc/sysconfig/network I guess bind shouldn't try to use IPv6 for lookups.

Comment 2 Renich Bon Ciric 2010-04-07 05:54:24 UTC
has this been looked at? still unresolved?

Comment 3 RHEL Program Management 2011-05-31 14:37:37 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Program Management 2012-04-02 10:37:14 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 5 Adam Tkac 2012-04-10 14:43:01 UTC
Are you still able to reproduce this issue, please? It is no longer present on my machine with the latest bind-9.3.6-20.P1.el5.

Comment 6 Colin.Simpson 2012-04-19 15:40:59 UTC
I still get this if I remove OPTIONS="-4" from /etc/sysconfig/named

I don't (unlike another on here have NETWORKING_IPV6=no) anywhere I just don't have IPv6 explicitly configured. 

/etc/sysconfig/network-scripts/ifcfg-bond0 :
DEVICE=bond0
IPADDR=10.1.50.10
NETMASK=255.255.255.0
USERCTL=no
BOOTPROTO=static
ONBOOT=yes
TYPE=Ethernet

So it is getting an IPv6 address (default):

[root@dns1 /]# /sbin/ifconfig bond0
bond0     Link encap:Ethernet  HWaddr 00:19:B9:F3:76:15  
          inet addr:10.1.50.10  Bcast:10.1.50.255  Mask:255.255.255.0
          inet6 addr: fe80::219:b9ff:fef3:7615/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:109560530 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112428679 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:77519021142 (72.1 GiB)  TX bytes:92995543557 (86.6 GiB)


Not sure what is required here (or documented best practice). Should we have IPv6 explicitly disabled (on this interface IPV6INIT=no)?

Maybe not a bug or I need to RTFM for best practice?

Comment 7 Petr Spacek 2012-05-03 10:24:55 UTC
I'm not sure if it's related to this issue, but there is an interesting RFC:
Default Address Selection for Internet Protocol version 6 (IPv6) http://tools.ietf.org/html/rfc3484

Cite:
... But if the node has assigned only a link-local IPv6 address and a global IPv4 address, then IPv4 is the best choice for communication. ...

Comment 8 RHEL Program Management 2012-06-12 01:18:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 Zdenek Wagner 2012-06-26 14:04:53 UTC
I have the same problem with CentOS release 5.8 (Final) running bind-9.3.6-20.P1.el5_8.1

IPv6 was always disabled in the configuration. After upgrade from 5.3 to 5.8 /sbin/ifconfig reported IPv6 adresses although /etc/sysconfig/networking/profiles/default/ifcfg-eth1 contains (and always contained) IPV6INIT=no
I used recommendation by Daniel Walsh as per https://bugzilla.redhat.com/show_bug.cgi?id=641836#c17 and /sbin/ifconfig now shows only IPv4 adresses yet logwatch sends me every day a few hundred messages as

 --------------------- Named Begin ------------------------


 **Unmatched Entries**
   network unreachable resolving '121.10.159.200.in-addr.arpa/PTR/IN': 2001:13c7:7002:3000::10#53: 1 Time(s)
   network unreachable resolving '121.10.159.200.in-addr.arpa/PTR/IN': 2001:67c:e0::3#53: 1 Time(s)
   network unreachable resolving '13.42.119.46.in-addr.arpa/PTR/IN': 2001:67c:e0::5#53: 1 Time(s)

IPv6 is still experimental on our LAN and all outgoing IPv6 traffic is intentionally blocked by the firewall.

Comment 10 Adam Tkac 2013-03-12 14:33:16 UTC
Since RHEL 5 is now in production phase 2 (only important/critical bugs are fixed), I'm closing this issue because it's not critical.

Please either specify OPTIONS='-4' in /etc/sysconfig/named to tell named not to use IPv6 or disable IPv6 completely on your machine. You can disable IPv6 this way:

Add

"options ipv6 disable=1" to /etc/modprobe.conf

and

"NETWORKING_IPV6=no" to /etc/sysconfig/network


Note You need to log in before you can comment on or make changes to this bug.