Bug 524241 - ethtool: typo in "speed 10000" command line parsing
ethtool: typo in "speed 10000" command line parsing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ethtool (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jay Fenlason
BaseOS QE
:
: 484168 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-18 09:46 EDT by David111
Modified: 2014-08-31 19:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3850 None None None Never

  None (edit)
Description David111 2009-09-18 09:46:23 EDT
Description of problem:
 http://bugs.centos.org/view.php?id=3850

 It prevents setting speed to 10000 ... Here's the patch:

--- ethtool.c 2007-07-26 19:22:06.000000000 +0200
+++ ethtool.c.new 2009-09-18 10:33:17.841224000 +0200
@@ -524,7 +524,7 @@
                                        speed_wanted = SPEED_1000;
                                else if (!strcmp(argp[i], "2500"))
                                        speed_wanted = SPEED_2500;
- else if (!strcmp(argp[1], "10000"))
+ else if (!strcmp(argp[i], "10000"))
                                        speed_wanted = SPEED_10000;
                                else
                                        show_usage(1);

Version-Release number of selected component (if applicable):
 ethtool-6-2.el5

How reproducible:


Steps to Reproduce:
1. sudo ethtool -s eth1 speed 10000
2.
3.
  
Actual results:
 print ethool usage

Expected results:
 setting the iface speed to 10000

Additional info:
 Also reported here: http://www.mail-archive.com/netdev@vger.kernel.org/msg58263.html
Comment 1 Jay Fenlason 2009-10-30 11:46:13 EDT
The fix for this is included in the patch for #529395
Comment 2 Jay Fenlason 2009-10-30 11:49:34 EDT
*** Bug 484168 has been marked as a duplicate of this bug. ***
Comment 5 Chris Ward 2010-02-11 05:21:50 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 6 David111 2010-02-16 05:19:24 EST
I guess I won't be able to test the fix:

"To access these Red Hat Network benefits, customers must log in to Red Hat Network using a Red Hat login associated with at least one active subscription to a Red Hat product or service."

Not my case, sorry, only CentOS here, and I'm not sure there's a CentOS 5.5 Beta out there ...
Comment 9 errata-xmlrpc 2010-03-30 04:46:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0279.html

Note You need to log in before you can comment on or make changes to this bug.