Bug 524254 - setroubleshoot: SELinux is preventing /usr/sbin/sedispatch "getcap" access.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/sedispatch "getcap" access.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:ca2c20c5bf5...
: 524255 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 14:51 UTC by Chris Poultney
Modified: 2009-09-18 15:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 15:04:57 UTC


Attachments (Terms of Use)

Description Chris Poultney 2009-09-18 14:51:11 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/sedispatch "getcap" access.

Detailed Description:

SELinux denied access requested by sedispatch. It is not expected that this
access is required by sedispatch and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:audisp_t:s0
Target Context                unconfined_u:system_r:audisp_t:s0
Target Objects                None [ process ]
Source                        sedispatch
Source Path                   /usr/sbin/sedispatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           setroubleshoot-server-2.2.18-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.26-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.i686.PAE #1 SMP Tue
                              Aug 11 21:01:03 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Fri 18 Sep 2009 07:37:04 AM BST
Last Seen                     Fri 18 Sep 2009 07:37:04 AM BST
Local ID                      a4d4d632-7873-4a69-afad-413b05081c60
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253255824.165:1911): avc:  denied  { getcap } for  pid=8394 comm="sedispatch" scontext=unconfined_u:system_r:audisp_t:s0 tcontext=unconfined_u:system_r:audisp_t:s0 tclass=process

node=(removed) type=SYSCALL msg=audit(1253255824.165:1911): arch=40000003 syscall=184 success=no exit=-13 a0=b7ef1944 a1=b7ef194c a2=60dff4 a3=b7ef1940 items=0 ppid=8393 pid=8394 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=7 comm="sedispatch" exe="/usr/sbin/sedispatch" subj=unconfined_u:system_r:audisp_t:s0 key=(null)


audit2allow suggests:

#============= audisp_t ==============
allow audisp_t self:process getcap;

Comment 1 Daniel Walsh 2009-09-18 15:04:57 UTC
Please yum update to latest policy.

Comment 2 Daniel Walsh 2009-09-18 15:06:44 UTC
*** Bug 524255 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.