Bug 524271 - setroubleshoot: SELinux is preventing /sbin/dhclient "getcap" access.
Summary: setroubleshoot: SELinux is preventing /sbin/dhclient "getcap" access.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0c7c2febf28...
: 524272 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 15:46 UTC by Haluk Dogan
Modified: 2009-09-18 21:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-18 21:07:22 UTC


Attachments (Terms of Use)

Description Haluk Dogan 2009-09-18 15:46:27 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /sbin/dhclient "getcap" access.

Detailed Description:

SELinux denied access requested by dhclient. It is not expected that this access
is required by dhclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:dhcpc_t:s0
Target Context                system_u:system_r:dhcpc_t:s0
Target Objects                None [ process ]
Source                        dhclient
Source Path                   /sbin/dhclient
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dhclient-4.1.0p1-8.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-23.fc12.i686 #1 SMP Wed Sep 16
                              16:09:25 EDT 2009 i686 i686
Alert Count                   3
First Seen                    Fri 18 Sep 2009 01:18:36 PM EEST
Last Seen                     Fri 18 Sep 2009 06:42:15 PM EEST
Local ID                      af353643-e2f2-432c-b2b7-629461534a38
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253288535.699:131): avc:  denied  { getcap } for  pid=2262 comm="dhclient" scontext=system_u:system_r:dhcpc_t:s0 tcontext=system_u:system_r:dhcpc_t:s0 tclass=process

node=(removed) type=SYSCALL msg=audit(1253288535.699:131): arch=40000003 syscall=184 success=no exit=-13 a0=b7fc16c4 a1=b7fc16cc a2=3a6ff4 a3=b7fc16c0 items=0 ppid=1144 pid=2262 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dhclient" exe="/sbin/dhclient" subj=system_u:system_r:dhcpc_t:s0 key=(null)


audit2allow suggests:

#============= dhcpc_t ==============
allow dhcpc_t self:process getcap;

Comment 1 Daniel Walsh 2009-09-18 21:07:22 UTC
Fixed in selinux-policy-3.6.32-3.fc12.noarch

Comment 2 Daniel Walsh 2009-09-18 21:08:21 UTC
*** Bug 524272 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.