Bug 52433 - dateconfig fails in shutting down ntpd, also timezone problems
dateconfig fails in shutting down ntpd, also timezone problems
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 14:21 EDT by Joshua Jensen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 16:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2001-08-23 14:21:01 EDT
Description of Problem:

when running dateconfig from the command line, it does two things in error:

It gives the message "Shutting down ntpd:         FAILED]
    This is confusing to users who *aren't* using ntpd

It does not have the default timezone, already configured, shown in the
time zone dialog.

Version-Release number of selected component (if applicable):

dateconfig-0.7.4-1



How Reproducible:

run dateconfig, look at the time zone dialog;
click on apply



Joshua
Comment 1 Brent Fox 2001-08-23 15:05:46 EDT
The timezone dialog works for me.  What are the contents of your
/etc/sysconfig/clock file?
Comment 2 Glen Foster 2001-08-24 13:08:04 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 3 Joshua Jensen 2001-08-24 14:39:11 EDT
The contents are:

ZONE="America/New_York"
UTC=false
ARC=false

Of course, these are the contents *after* using dateconfig, seeing no timezone,
and then selecting a timezone.
Comment 4 Brent Fox 2001-09-04 11:22:30 EDT
That's too bad.  I wanted to know the contents of the file before dateconfig was
run.  dateconfig should be able to read you current timezone and auto select it
in the list, so I'm curious as to what was in the file before dateconfig
overwrote it.
Comment 5 Joshua Jensen 2001-09-04 16:57:01 EDT
I just did an RC2 install, and I haven't run dateconfig yet.  I will try it out
this evening, makeing a backup of /etc/sysconfig/clock before using dateconfig.
Comment 6 Joshua Jensen 2001-09-04 23:27:49 EDT
Well, in RC2 /etc/sysconfig/clock says:
ZONE="America/New_York"
UTC=false
ARC=false

When I start dateconfig, I can't reproduce the problem.  It looks like everything is 
good in RC2.

Thanks,

Joshua

Note You need to log in before you can comment on or make changes to this bug.