Bug 524358 - Broken dependencies in updates from Sep 19
Summary: Broken dependencies in updates from Sep 19
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 12:09 UTC by Joachim Backes
Modified: 2014-01-21 23:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-20 14:26:48 UTC


Attachments (Terms of Use)

Description Joachim Backes 2009-09-19 12:09:13 UTC
Description of problem:
"yum update" has dependency problems:

sudo yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package farsight2.i686 0:0.0.15-2.fc12 set to be updated
--> Processing Dependency: libgssdp-1.0.so.1 for package: nautilus-sendto-1.1.7-2.fc12.i686
---> Package gssdp.i686 0:0.7.0-2.fc12 set to be updated
--> Processing Dependency: libgupnp-1.0.so.2 for package: nautilus-sendto-1.1.7-2.fc12.i686
---> Package gupnp.i686 0:0.13.0-1.fc12 set to be updated
--> Processing Dependency: libgupnp-av-1.0.so.1 for package: nautilus-sendto-1.1.7-2.fc12.i686
---> Package gupnp-av.i686 0:0.5.1-1.fc12 set to be updated
---> Package gupnp-igd.i686 0:0.1.3-3.fc12 set to be updated
---> Package libnice.i686 0:0.0.9-2.fc12 set to be updated
--> Finished Dependency Resolution
nautilus-sendto-1.1.7-2.fc12.i686 from installed has depsolving problems
  --> Missing Dependency: libgupnp-1.0.so.2 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
nautilus-sendto-1.1.7-2.fc12.i686 from installed has depsolving problems
  --> Missing Dependency: libgssdp-1.0.so.1 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
nautilus-sendto-1.1.7-2.fc12.i686 from installed has depsolving problems
  --> Missing Dependency: libgupnp-av-1.0.so.1 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
Error: Missing Dependency: libgupnp-av-1.0.so.1 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
Error: Missing Dependency: libgupnp-1.0.so.2 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
Error: Missing Dependency: libgssdp-1.0.so.1 is needed by package nautilus-sendto-1.1.7-2.fc12.i686 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):

yum-3.2.24-4.fc12.noarch
How reproducible:
Each time

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
See above

Expected results:
yum updates runs without broken dependencies

Additional info:

"yum update --skip-broken" loads the remaining updates

Comment 1 Tim Lauridsen 2009-09-20 07:49:29 UTC
This is not a bug in yum, please report the bug to the package causing the problem
nautilus-sendto in this case.


Note You need to log in before you can comment on or make changes to this bug.