Bug 52436 - pump is has problems with roadrunner
Summary: pump is has problems with roadrunner
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: pump   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 18:40 UTC by sahag
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 02:25:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sahag 2001-08-23 18:40:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2 i686)

Description of problem:
if lo interface is up pump is unable to detect the network settings.
if lo is down pump works perfectly

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./sbin/ifup lo
2./sbin/ifup eth0

	

Actual Results:  Determining IP information for eth0...Operation failed.
 failed.


Expected Results:  Determining IP information for eth0... done.

Additional info:

if i do
/sbin/ifdown lo
/sbin/ifup eth0
/sbin/ifup lo
everything works perfectly. I am using roadrunner.
these are the logs of pump while running with lo active.

Aug 23 14:23:46 ani pumpd[2464]: PUMP: sending discover 
Aug 23 14:23:46 ani pumpd[2464]: breq: opcode: 1
Aug 23 14:23:46 ani pumpd[2464]: breq: hw: 1
Aug 23 14:23:46 ani pumpd[2464]: breq: hwlength: 6
Aug 23 14:23:46 ani pumpd[2464]: breq: hopcount: 0
Aug 23 14:23:46 ani pumpd[2464]: breq: xid: 0x8f5bb15e
Aug 23 14:23:46 ani pumpd[2464]: breq: secs: 0
Aug 23 14:23:46 ani pumpd[2464]: breq: flags: 0x0000
Aug 23 14:23:46 ani pumpd[2464]: breq: ciaddr: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: yiaddr: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: server_ip: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: bootp_gw_ip: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: hwaddr: 
Aug 23 14:23:46 ani pumpd[2464]: breq: servername: 
Aug 23 14:23:46 ani pumpd[2464]: breq: bootfile: 
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor: 0x63 0x53 0x82 0x63
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor:  53   1 0x01
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor: 0xff
Aug 23 14:23:46 ani kernel: eth0: 0 multicast blocks dropped.
Aug 23 14:23:46 ani pumpd[2464]: PUMP: sending discover 
Aug 23 14:23:46 ani pumpd[2464]: breq: opcode: 1
Aug 23 14:23:46 ani pumpd[2464]: breq: hw: 1
Aug 23 14:23:46 ani pumpd[2464]: breq: hwlength: 6
Aug 23 14:23:46 ani pumpd[2464]: breq: hopcount: 0
Aug 23 14:23:46 ani pumpd[2464]: breq: xid: 0x8f5bb15e
Aug 23 14:23:46 ani pumpd[2464]: breq: secs: 0
Aug 23 14:23:46 ani pumpd[2464]: breq: flags: 0x0000
Aug 23 14:23:46 ani pumpd[2464]: breq: ciaddr: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: yiaddr: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: server_ip: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: bootp_gw_ip: 0.0.0.0
Aug 23 14:23:46 ani pumpd[2464]: breq: hwaddr: 
Aug 23 14:23:46 ani pumpd[2464]: breq: servername: 
Aug 23 14:23:46 ani pumpd[2464]: breq: bootfile: 
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor: 0x63 0x53 0x82 0x63
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor:  53   1 0x01
Aug 23 14:23:46 ani pumpd[2464]: breq: vendor: 0xff

Comment 1 Ed McKenzie 2001-08-24 02:25:08 UTC
I see this too.  dhcpcd works perfectly; pump seems to work after a reboot, but
it breaks as soon as the lease expires.


Comment 2 sahag 2001-09-06 19:09:21 UTC
After upgrading a bunch of packages from beta red hat network server this bug
disappeared.
my guess is that one of the following packages fixed the problem : kernel,
kernel-pcmcia or pump

so i close this bug since it's working for me now.



Note You need to log in before you can comment on or make changes to this bug.