Bug 524363 - corrupt rendered menu in wine and team fortress 2 (hl2.exe)
Summary: corrupt rendered menu in wine and team fortress 2 (hl2.exe)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 12:56 UTC by Robert Laverick
Modified: 2018-04-11 07:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-01 13:52:54 UTC


Attachments (Terms of Use)
image of corruption - find server dialog (392.55 KB, image/png)
2009-09-19 12:57 UTC, Robert Laverick
no flags Details
image of corruption - charactor info (441.65 KB, image/png)
2009-09-19 12:58 UTC, Robert Laverick
no flags Details
wine output during testing (25.69 KB, text/plain)
2009-09-19 12:58 UTC, Robert Laverick
no flags Details
dmesg output (48.09 KB, text/plain)
2009-09-30 17:29 UTC, Robert Laverick
no flags Details
X.org log (94.63 KB, text/plain)
2009-09-30 17:29 UTC, Robert Laverick
no flags Details

Description Robert Laverick 2009-09-19 12:56:08 UTC
Description of problem:
corruption in dialogs being rendered in tf2 via wine

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.x86_64
wine-1.1.29-3.fc12.x86_64
mesa-libGLU-7.6-0.12.fc12.x86_64
mesa-libGLU-7.6-0.12.fc12.i686
kernel-2.6.31-33.fc12.x86_64

How reproducible:
every time

Steps to Reproduce:
1.Install Wine, Steam and Team Fortress 2
2.disable "Allow Pixel Shader (if supported by hardware)" enabled in winecfg - to avoid bug 524361
3.launch tf2
4.select a menu item that will cause a dialog to open, i.e. find server
  
Actual results:
crazy game screen corruption - errors attempting to render - see screenshots attached

Expected results:
dialog rendered correctly

Additional info:

Comment 1 Robert Laverick 2009-09-19 12:57:02 UTC
Created attachment 361760 [details]
image of corruption - find server dialog

Comment 2 Robert Laverick 2009-09-19 12:58:11 UTC
Created attachment 361761 [details]
image of corruption - charactor info

Comment 3 Robert Laverick 2009-09-19 12:58:47 UTC
Created attachment 361762 [details]
wine output during testing

Comment 4 Matěj Cepl 2009-09-30 14:45:29 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 5 Matěj Cepl 2009-09-30 14:49:20 UTC
Throwing the bug wine folks for further analysis. I don't think this could work at all. If you have any reason to believe that this should work, please, provide the information in comment 4 and reassign back.

Thank you.

Comment 6 Andreas Bierfert 2009-09-30 15:00:03 UTC
Please provide the wine version you are using and all installed wine packages.

Comment 7 Robert Laverick 2009-09-30 17:28:47 UTC
wine-esd-1.1.29-3.fc12.i686
wine-core-1.1.29-3.fc12.i686
wine-ldap-1.1.29-3.fc12.i686
wine-1.1.29-3.fc12.x86_64
wine-twain-1.1.29-3.fc12.x86_64
wine-oss-1.1.29-3.fc12.x86_64
wine-capi-1.1.29-3.fc12.x86_64
wine-cms-1.1.29-3.fc12.i686
wine-common-1.1.29-3.fc12.noarch
wine-fonts-1.1.29-3.fc12.noarch
wine-core-1.1.29-3.fc12.x86_64
wine-alsa-1.1.29-3.fc12.x86_64
wine-alsa-1.1.29-3.fc12.i686
wine-ldap-1.1.29-3.fc12.x86_64
wine-cms-1.1.29-3.fc12.x86_64
wine-capi-1.1.29-3.fc12.i686
wine-esd-1.1.29-3.fc12.x86_64
wine-pulseaudio-1.1.29-3.fc12.x86_64
wine-pulseaudio-1.1.29-3.fc12.i686
wine-oss-1.1.29-3.fc12.i686
wine-twain-1.1.29-3.fc12.i686
wine-desktop-1.1.29-3.fc12.noarch

TF2 does work under F11 with the binary drivers using what reports to be the same version of the wine packages - tho fc11, so I had assumed this was a graphics issues with the OSS ati drivers (which are obviously new and therefore going to have problems with more complex apps like this, but I still thought it worth reporting).

The corruption is independant of kernel mode setting, and I have since the inital report updated to the following related version, note that currently I am unable to run kernel mode setting due to bug 525904 tho this bug occurs with or without kernel mode setting.

mesa-libGLU-devel-7.6-0.13.fc12.i686
mesa-dri-drivers-7.6-0.13.fc12.i686
mesa-libGL-devel-7.6-0.13.fc12.x86_64
mesa-libGL-devel-7.6-0.13.fc12.i686
mesa-libGL-7.6-0.13.fc12.x86_64
mesa-dri-drivers-experimental-7.6-0.13.fc12.x86_64
kernel-firmware-2.6.31.1-48.fc12.noarch
kernel-2.6.31.1-48.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.5.20090929git7968e1fb8.fc12.x86_64
mesa-dri-drivers-7.6-0.13.fc12.x86_64
mesa-libGLU-7.6-0.13.fc12.x86_64
kernel-2.6.31-40.fc12.x86_64
kernel-headers-2.6.31.1-48.fc12.x86_64
mesa-libGLU-devel-7.6-0.13.fc12.x86_64
mesa-libGL-7.6-0.13.fc12.i686
mesa-libGLU-7.6-0.13.fc12.i686
kernel-2.6.31-33.fc12.x86_64

Comment 8 Robert Laverick 2009-09-30 17:29:20 UTC
Created attachment 363206 [details]
dmesg output

Comment 9 Robert Laverick 2009-09-30 17:29:51 UTC
Created attachment 363207 [details]
X.org log

Comment 10 Bug Zapper 2009-11-16 12:38:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Robert Laverick 2010-02-01 13:52:54 UTC
This seems to now be fixed for me.


Note You need to log in before you can comment on or make changes to this bug.