Bug 524376 - [abrt] crash detected in gpodder-2.0-1.fc12
Summary: [abrt] crash detected in gpodder-2.0-1.fc12
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:09ac5294
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-19 15:46 UTC by Matěj Cepl
Modified: 2018-04-11 12:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-31 21:40:08 UTC


Attachments (Terms of Use)
File: backtrace (3.67 KB, text/plain)
2009-09-19 15:46 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2009-09-19 15:46:28 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Hmm, this is quite certainly full-bloodied gpodder 2.0

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python /usr/bin/gpodder 


component
-----
gpodder


executable
-----
/usr/bin/gpodder


kernel
-----
2.6.31-23.fc12.x86_64


package
-----
gpodder-2.0-1.fc12


uuid
-----
09ac5294

Comment 1 Matěj Cepl 2009-09-19 15:46:31 UTC
Created attachment 361769 [details]
File: backtrace

Comment 2 Jef Spaleta 2009-09-20 06:23:00 UTC
Okay looking at the backtrace it looks like the segfault is actually from the 
/usr/libexec/gst-install-plugins-helper

gpodder does not call this directly.  In fact gpodder doesn't depend on gstreamer at all.

gpodder by default is setup to use xdg-open which in turn should be default be spawning totem a gstreamer based application.

Totem will potentially end up starting up gst-install-plugin-helper when accessing a file type/ codec that your system doesn't support.

The same segfault should happen if you attempt to play whatever file you were trying to play using totem directly. Or in fact...any gstreamer based application should result in this backtrace as the mechanism which starts gst-install-plugins-helper is associated with gstreamer.


I'm not sure where you should refile this, but its definitely not gpodder specific.

Comment 3 Matěj Cepl 2009-10-31 21:40:08 UTC
Moreover, I have to declare anticipatory breach ... meaning I have managed to fix Rhythmbox, so that it works for me again, and I have left gpodder behind.

Closing this as INSUFFICIENT_DATA, because not much more will come from me.


Note You need to log in before you can comment on or make changes to this bug.