Bug 5244 - ruserd give a growing number of users
Summary: ruserd give a growing number of users
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rusers   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-20 13:52 UTC by christian.bac
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 14:18:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description christian.bac 1999-09-20 13:52:35 UTC
due to the initialization of static variable the number of
users that rusersd gives back is always growing:

fix : in rusers_proc.c
with a diff -e for example 200c193
<         static int num_users = 0;
---
>         static int num_users ;
206c199
<
---
>       num_users =0;

Comment 1 Jeff Johnson 1999-09-20 14:18:59 UTC
Fixed in rusers-0.15-5. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.