Bug 52459 - dumping onto IDE tape using PE500 hangs system
Summary: dumping onto IDE tape using PE500 hangs system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 21:35 UTC by Tesfamariam Michael
Modified: 2005-10-31 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 19:11:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of `cat /proc/ide/hdd/settings` where hdd is the ide tape (1.88 KB, text/plain)
2001-08-24 18:16 UTC, Tesfamariam Michael
no flags Details

Description Tesfamariam Michael 2001-08-23 21:35:31 UTC
Description of Problem:
Using PowerEdge 500 and Seagate TR5 IDE tape drive (10/20GB 
capacity with firmware 8A51), dumping/restoring data hangs the system.

Version-Release number of selected component (if applicable):
Fairfax RC1

How Reproducible:
Always

Steps to Reproduce:
1. Boot PowerEdge 500 that has Seagate TR5 IDE tape drive with Fairfax RC1
2. "tar -cvf /dev/ht0 /usr/share/doc"
3. The system hangs

Actual Results:
As soon as the tape is accessed, the system hangs.

Expected Results:
Dumping and restoring data using an IDE tape should complete without any 
problem. 

Additional Information:
DMA for the tape drive is enabled by default and the issue occures with 
DMA enabled. Once DMA is disabled and ide-scsi module used ("rmmod ide-
tape" and "modprobe ide-scsi"), all works fine.
This issue was also seen with RH7.1. Other issues are also seen with IDE 
tape, see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=38404 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=36628

Comment 1 Glen Foster 2001-08-24 15:51:21 UTC
This defect is considered MUST-FIX for Fairfax.

Comment 2 Arjan van de Ven 2001-08-24 16:05:28 UTC
Did the new kernel work ?

Comment 3 Tesfamariam Michael 2001-08-24 17:53:07 UTC
DMA is still enabled with kernel-2.4.7-2.7.i686.rpm. I downloaded this RPM from 
your site, installed it, remake my initrd image, rebooted the system with this 
new image, but DMA was still enabled for the tape drive and the system hanged 
when trying to access it.
If you need to add it to the ide-dma.c black list, `cat /proc/ide/hdd/model` 
gives "Seagate STT20000A".

Comment 4 Arjan van de Ven 2001-08-24 17:59:03 UTC
can you attach the /proc/ide/hdd/settings file please ?
(I've added it to blacklist as well)

Comment 5 Tesfamariam Michael 2001-08-24 18:16:33 UTC
Created attachment 29395 [details]
Output of `cat /proc/ide/hdd/settings` where hdd is the ide tape

Comment 6 Michael K. Johnson 2001-08-30 20:42:44 UTC
Quite sure fixed for RC2, please test as soon as you get it
(or test the -2.18 kernel Arjan posted to roswell-list about
earlier, that will also have the fix)

Comment 7 Tesfamariam Michael 2001-09-05 18:15:29 UTC
Issue still exists with Fairfax RC2. DMA is enabled for the ide-tape device by 
default.

Comment 8 Tesfamariam Michael 2001-09-06 21:40:56 UTC
It is failing with kernel 2.4.7-6 (Fairfax RC2).

Comment 9 Tesfamariam Michael 2001-09-07 20:40:41 UTC
Using 2.4.7-7 kernel (from Rawhide):
DMA was disabled for this device during install (2.4.7-7BOOT kernel). But DMA 
is enabled when booting system with this kernel, in which case the system hangs 
as soon as the tape is accessed (with DMA enabled).

Comment 10 Bill Nottingham 2001-09-20 19:25:33 UTC
Does this also persist in the final release?

Comment 11 Michael K. Johnson 2001-09-20 20:39:18 UTC
I have now reproduced this on a seagate TR5 on a PE500 with 2.4.7-10.
/proc/ide/hdc/settings (it's a master in my setup) shows using_dma as
"0"  Using "ide=nodma" works around the problem without bothering with
ide-scsi at all.
Well, not quite reproduced.  I can do some I/O to the tape; it took
about a minute for the system to hang.  Once it hangs, it hangs with
interrupts disabled.

Since this hasn't been reproduced on anything but a PE500 as far as
I know, I suspect OSB5 driver.


Comment 12 Michael K. Johnson 2001-09-20 21:45:03 UTC
Typo, I means "CSB5" driver, not "OSB5" driver.

I have also tested this with 2.4.9-0.8.2, which has some IDE cleanups,
but the results were exactly the same; ide=nodma is required to make
the device work.

Have you reproduced this on any other machine besides the PE500?

Comment 13 Tesfamariam Michael 2001-09-20 22:39:30 UTC
The hang occurs only on PE500.

Comment 14 Michael K. Johnson 2001-09-26 23:23:32 UTC
That's your only hardware that uses the CSB5 driver, right?
More evidence that it is a bug in that particular driver.

Comment 15 Tesfamariam Michael 2001-10-11 15:37:50 UTC
Yes, at this time, that is the only system that uses CSB5.

Comment 16 Matt Domsch 2001-11-05 16:41:54 UTC
Trimming the cc: list.

Comment 17 Joshua Giles 2002-03-28 20:26:22 UTC
Still happens in Hampton beta 3

Comment 18 Arjan van de Ven 2002-04-09 12:26:03 UTC
initscripts have been modified to disable DMA on tapes and cdrom drives by
default.

Comment 19 Michael K. Johnson 2002-04-15 19:11:25 UTC
Unfortunately, at least in our testing here, disabling DMA only for the
tape/cdrom was not sufficient.  This is either a CSB5 driver bug or a
simple hardware bug.

Comment 20 John A. Hull 2002-08-16 16:28:34 UTC
Closing as hardware bug.


Note You need to log in before you can comment on or make changes to this bug.