Bug 524616 - _uid_ses keyring being cleaned up twice.
Summary: _uid_ses keyring being cleaned up twice.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Dave Anderson
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 499522 533192
TreeView+ depends on / blocked
 
Reported: 2009-09-21 13:51 UTC by Casey Dahlin
Modified: 2018-10-27 14:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-08 22:17:28 UTC


Attachments (Terms of Use)

Description Casey Dahlin 2009-09-21 13:51:33 UTC
Description of problem:
Customer is getting kernel panics due to list_del being called on an already freed list entry. The reason appears to be that the _uid_ses keyring is being cleaned up twice.

Version-Release number of selected component (if applicable):
kernel 2.6.18-8

How reproducible:
Customer sees this regularly when there are a large number of logins and logouts.

Comment 1 Casey Dahlin 2009-09-21 15:16:56 UTC
Have there been panics like this in the past? What's a good technique for finding the culprit in this case? I've tried systemtap but you can't guarantee the integrity of a disk log after a panic, and getting the stap logs out of a core file has proved ugly.

Comment 2 Dave Anderson 2009-09-21 17:40:21 UTC
Is there a vmlinux/vmcore pair that I can look at?


Note You need to log in before you can comment on or make changes to this bug.