Bug 524632 - Rotating screen in Xfce4 and cursor
Summary: Rotating screen in Xfce4 and cursor
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 14:54 UTC by Tomas Pelka
Modified: 2018-04-11 14:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-08 22:20:26 UTC


Attachments (Terms of Use)
Xorg.conf (78 bytes, text/plain)
2009-09-22 15:28 UTC, Tomas Pelka
no flags Details
dmesg (55.13 KB, text/plain)
2009-09-22 15:30 UTC, Tomas Pelka
no flags Details
Xorg.0.log (53.81 KB, text/plain)
2009-09-22 15:32 UTC, Tomas Pelka
no flags Details

Description Tomas Pelka 2009-09-21 14:54:55 UTC
Description of problem:
When I rotate the screen Right/Left/Inverted and than back to normal, mouse cursor stay rotated, till I move them out of currently focused window (xfce4-display-settings).

Version-Release number of selected component (if applicable):
xfce4-settings-4.6.1-4.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Log in to the Xfce4 session.
2. Run Preferences->Display and try to rotate screen (Left/Right/Inverted). Click on Apply.
3. Set back to Normal and apply this setting again.
4. Watch the cursor.
  
Actual results:
Cursor stay rotated.

Expected results:
Cursor should rotate right after applying changes, not after change focus or after move the cursor out from the focused window.  

Additional info:

Comment 1 Kevin Fenzi 2009-09-22 02:19:52 UTC
Hum. 

If you use 'xrandr --rotate left' and then 'xrandr --rotate right' does it do the same thing? 

Ie, is this a bug in the interface, or in xrandr itself?

Comment 2 Tomas Pelka 2009-09-22 06:54:39 UTC
Xrandr from cli cause the same problem.

Changing component to xorg-x11-server-utils.

Additional info:
xorg-x11-server-utils-7.4-11.fc12.x86_64

Comment 3 Matěj Cepl 2009-09-22 15:22:18 UTC
Looks hardware dependent to me, I cannot reproduce here with intel chipset. So, we need some more information about your seutp.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Tomas Pelka 2009-09-22 15:28:52 UTC
Created attachment 362108 [details]
Xorg.conf

Comment 5 Tomas Pelka 2009-09-22 15:30:36 UTC
Created attachment 362109 [details]
dmesg

Comment 6 Tomas Pelka 2009-09-22 15:32:27 UTC
Created attachment 362110 [details]
Xorg.0.log

Comment 7 Matěj Cepl 2009-09-22 22:07:41 UTC
Hmm, kernel guys could be interested in the following, but nothing for us, Xorg developers:

generic-usb 0003:413C:3012.0001: input,hidraw0: USB HID v1.11 Mouse [Dell Dell USB Optical Mouse] on usb-0000:00:1d.1-2/input0
------------[ cut here ]------------
WARNING: at kernel/trace/ftrace.c:1003 ftrace_bug+0x198/0x27e() (Not tainted)
Hardware name: Precision WorkStation T5400  
Modules linked in: i2c_core(+)
Pid: 171, comm: modprobe Not tainted 2.6.31-14.fc12.x86_64 #1
Call Trace:
 [<ffffffff81064244>] warn_slowpath_common+0x95/0xc3
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff81064299>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810d4a0e>] ftrace_bug+0x198/0x27e
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5c66>] ftrace_convert_nops+0x201/0x2b9
 [<ffffffffa0003072>] ? i2c_new_dummy+0x8/0x5e [i2c_core]
 [<ffffffff810d5d6a>] ftrace_module_notify+0x4c/0x7f
 [<ffffffff815099a5>] notifier_call_chain+0x72/0xba
 [<ffffffff81086db1>] ? __blocking_notifier_call_chain+0x4c/0x8e
 [<ffffffff81086dc8>] __blocking_notifier_call_chain+0x63/0x8e
 [<ffffffff81086e1a>] blocking_notifier_call_chain+0x27/0x3d
 [<ffffffff810a466a>] sys_init_module+0xb7/0x249
 [<ffffffff81011f42>] system_call_fastpath+0x16/0x1b
---[ end trace cb83e1ffbd55ce93 ]---
ftrace faulted on writing [<ffffffffa0003072>] i2c_new_dummy+0x8/0x5e [i2c_core]

Comment 8 Ben Skeggs 2009-10-08 06:37:43 UTC
The build at http://koji.fedoraproject.org/koji/taskinfo?taskID=1734753 should fix this issue.

Are you able to test it and confirm?  Thanks.

Dave, it looks like radeon needs a similar fix (call xf86_reload_cursors() from drmmode_set_mode_major()).

Comment 9 Tomas Pelka 2009-10-08 10:11:52 UTC
Tested and confirmed, thanks Ben

Comment 10 Ben Skeggs 2009-10-08 22:20:26 UTC
Thank you!


Note You need to log in before you can comment on or make changes to this bug.