Bug 524675 - Confusion in patch linux-2.6-raidlockdep.patch
Summary: Confusion in patch linux-2.6-raidlockdep.patch
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 17:24 UTC by Quentin Armitage
Modified: 2009-09-24 02:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 02:35:34 UTC


Attachments (Terms of Use)

Description Quentin Armitage 2009-09-21 17:24:14 UTC
Description of problem:
If the F-12 branch, the above patch causes the following message about the patch ending in the middle of a line. It is caused by line 40 of the patch (---)

+ ApplyPatch linux-2.6-raidlockdep.patch
+ local patch=linux-2.6-raidlockdep.patch
+ shift
+ '[' '!' -f /builddir/build/SOURCES/linux-2.6-raidlockdep.patch ']'
Patch14002: linux-2.6-raidlockdep.patch
+ case "$patch" in
+ patch -p1 -F1 -s
patch unexpectedly ends in middle of line
patch unexpectedly ends in middle of line

Version-Release number of selected component (if applicable):
kernel-2.6.31-33.fc12

How reproducible:
Always

Steps to Reproduce:
1. Build kernel
2.
3.
  
Actual results:
patch messages above

Expected results:
No such messages

Additional info:

Comment 1 Chuck Ebbert 2009-09-24 02:35:34 UTC
just a warning caused by the last line not having a newline at the end


Note You need to log in before you can comment on or make changes to this bug.