Bug 52469 - %post/pre scriptlets should use the `if [ $1..' logic
%post/pre scriptlets should use the `if [ $1..' logic
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: wine (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 21:12 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 12:25:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-08-23 21:12:20 EDT
The %post/%pre scriptlets of wine-20010822-1 are executed without doing the
usual `if [ $1 ...' tests:

| $ rpm -q --scripts wine
| preinstall scriptlet (through /bin/sh):
| /usr/sbin/groupadd -r wine &>/dev/null || :
| ...
| postuninstall scriptlet (through /bin/sh):
| perl -pi -e "s,^/usr/lib/wine$,,g" /etc/ld.so.conf
| /sbin/ldconfig
| /usr/sbin/groupdel wine &>/dev/null || :


When doing an upgrade, the `groupadd' of the %preinstall will be annuled by
the `groupdel' of the %postuninstall immediately.
Comment 1 Enrico Scholz 2002-02-22 18:52:44 EST
Still in wine-20020221-1
Comment 2 Enrico Scholz 2002-02-22 18:57:55 EST
Increased severity because %postuninstall removes paths from /etc/ld.so.conf and
wine does not work after an upgrade therefore:

| $ wine
| wine: error while loading shared libraries: libntdll.so: cannot open shared
object file: No such file or directory
Comment 3 Enrico Scholz 2002-03-05 12:25:14 EST
Still in wine-20020226-1
Comment 4 Bernhard Rosenkraenzer 2002-03-27 09:04:41 EST
This was fixed some time ago.

Note You need to log in before you can comment on or make changes to this bug.