Bug 524718 - Satellite 5.3.0 rhn-upgrade package needs to include location of schema-upgrade logs in the upgrade instruction/documentation
Summary: Satellite 5.3.0 rhn-upgrade package needs to include location of schema-upgra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks: sat531-blockers 523386
TreeView+ depends on / blocked
 
Reported: 2009-09-21 21:04 UTC by Xixi
Modified: 2010-01-30 03:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 14:36:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1479 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2009-10-06 14:35:58 UTC

Description Xixi 2009-09-21 21:04:01 UTC
Description of problem:
rhn-upgrade documentation needs to include schema upgrade log locations for /usr/bin/spacewalk-schema-upgrade and instruct users to check the logs for errors before heading to next step.

Some customers didn't know to check the logs (or where) so completed the rest of the upgrade even though schema upgrade had issues.

Version-Release number of selected component (if applicable):
Red Hat Network Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Look at /etc/sysconfig/rhn/satellite-upgrade/rhn-satellite-5-upgrade-scenario-1a.txt and /etc/sysconfig/rhn/satellite-upgrade/rhn-satellite-5-upgrade-scenario-1b.txt and grep for /usr/bin/spacewalk-schema-upgrade.
2. Look at the section "Upgrade your database schema using spacewalk-schema-upgrade command
   (see manual page for spacewalk-schema-upgrade for more information):
      /usr/bin/spacewalk-schema-upgrade".
3.
  
Actual results:
There's no mention of location of log file or that user should check the log files to make sure there no errors before proceeding.

Expected results:
There needs to be a blurb mentioning to check log files under /var/log/spacewalk/schema-upgrade/ for any errors (such as ORA-*) before proceeding.  If there're errors, they should stop the upgrade and contact Red Hat support immediately.

Additional info:

Comment 1 Milan Zázrivec 2009-09-22 12:48:45 UTC
While it is true that the upgrade documentation does not explicitly mention
the location of schema upgrade scripts, spacewalk-schema-upgrade script
always mentions the specific location of sql log files just before user
confirms the wish to continue with the schema upgrade.

Also, whenever schema upgrade process fails, spacewalk-schema-upgrade
informs of the failure with a message like:

    "Upgrade failed, please see log in ..."

Finish of a successful upgrade then looks like:

    "The database schema was upgraded to version ..."

I wonder what the output from the script looked like for the customers
for whom the schema upgrade produced some ORA-... errors and carried on
with the remaining steps of upgrade (the script is designed to stop at
that very moment ...)

What I added into the upgrade documentation for the schema upgrade step:

* Where to look for the sql log files

* What the output from a successful schema upgrade looks like

* What the output from a failed schema upgrade looks like

* In case of failed schema upgrade, contact Red Hat Support and have the
sql log files prepared.

satellite.git, SATELLITE-5.3: 1908344d6fa14e4c3dbc1e016bf37f6687b27c73

Comment 4 Milan Zázrivec 2009-09-25 07:41:28 UTC
rhn-upgrade-5.3.0.24-1.el4sat & rhn-upgrade-5.3.0.23-1.el5sat

Comment 5 Jan Hutař 2009-09-29 10:40:48 UTC
VERIFIED on rhn-upgrade-5.3.0.24-1.el4sat:

rhn-satellite-5-upgrade-scenario-1a.txt:
   [...]
   NOTE 2: the script puts all SQL logs from schema upgrade under
           /var/log/spacewalk/schema-upgrade directory (running script will
           inform you of the exact file names).

   NOTE 3: Should the schema upgrade fail, script finishes with following message:

           "Upgrade failed, please see log in ..."

           In case of failed schema upgrade, prepare the log files and contact
           Red Hat Support immediately.

   NOTE 4: For successful schema upgrade, script prints following message:

           "The database schema was upgraded to version ..."
   [...]

rhn-satellite-5-upgrade-scenario-1b.txt:
   [...]
   NOTE 2: the script puts all SQL logs from schema upgrade under
           /var/log/spacewalk/schema-upgrade directory (running script will
           inform you of the exact file names).

   NOTE 3: Should the schema upgrade fail, script finishes with following message:

           "Upgrade failed, please see log in ..."

           In case of failed schema upgrade, prepare the log files and contact
           Red Hat Support immediately.

   NOTE 4: For successful schema upgrade, script prints following message:

           "The database schema was upgraded to version ..."
   [...]

Comment 6 Petr Sklenar ⛄ 2009-10-01 15:43:27 UTC
Verified also with rhn-upgrade-5.3.0.24-1.el5sat :

file: rhn-satellite-5-upgrade-scenario-1{a}.txt
step: 10. Convert database schema (your DBA may want to do this for you):

file: rhn-satellite-5-upgrade-scenario-1{b}.txt
step: 2. Conversion of database schema

................
  NOTE 2: the script puts all SQL logs from schema upgrade under
           /var/log/spacewalk/schema-upgrade directory (running script will
           inform you of the exact file names).

   NOTE 3: Should the schema upgrade fail, script finishes with following
message:

           "Upgrade failed, please see log in ..."

           In case of failed schema upgrade, prepare the log files and contact
           Red Hat Support immediately.

   NOTE 4: For successful schema upgrade, script prints following message:
....


+ script /usr/bin/satellite-5.3.0-schema-upgrade created logs :

[root@dhcp-lab-163 newsat]# /usr/bin/satellite-5.3.0-schema-upgrade
Schema upgrade: [rhn-satellite-schema-5.2.0-8] -> [satellite-schema-5.3.0.23-1.el5sat]
Searching for upgrade path: [rhn-satellite-schema-5.2.0-8] -> [satellite-schema-5.3.0.23-1]
Searching for upgrade path: [rhn-satellite-schema-5.2.0] -> [satellite-schema-5.3.0.23]
Searching for upgrade path: [rhn-satellite-schema-5.2] -> [satellite-schema-5.3.0]
Searching for upgrade path: [rhn-satellite-schema-5.2] -> [satellite-schema-5.3]
The path: [rhn-satellite-schema-5.2] -> [satellite-schema-5.3]
Planning to run sqlplus with [/var/log/spacewalk/schema-upgrade/20091001-114123-script.sql]
Hit Enter to continue or Ctrl+C to interrupt: 
Executing sqlplus, the logs are in /var/log/spacewalk/schema-upgrade/20091001-114123-*.

Comment 8 errata-xmlrpc 2009-10-06 14:36:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1479.html


Note You need to log in before you can comment on or make changes to this bug.