Bug 524728 - plugin search does not use packages from rpmfusion-free-updates
Summary: plugin search does not use packages from rpmfusion-free-updates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 23:03 UTC by Mark Watts
Modified: 2010-03-23 09:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-23 09:37:07 UTC


Attachments (Terms of Use)

Description Mark Watts 2009-09-21 23:03:56 UTC
Trying to play an AAC file from my iPod in rhythmbox on Fedora 11. (rhythmbox-0.12.3-1.fc11.i586)

I have both rpmfusion-free and rpmfusion-free-updates (along with the nonfree versions).

When trying to play the file, a dialog pops up asking if I want to search for the relevant plugins, to which I choose "yes".
The following appears:

Test Transaction Errors:   file /usr/lib/gstreamer-0.10/libgstdeinterlace.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.i586 conflicts with file from package gstreamer-plugins-good-0.10.15-4.fc11.i586
  file /usr/lib/gstreamer-0.10/libgstflv.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.i586 conflicts with file from package gstreamer-plugins-good-0.10.15-4.fc11.i586
  file /usr/lib/gstreamer-0.10/libgstrtpmanager.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.i586 conflicts with file from package gstreamer-plugins-good-0.10.15-4.fc11.i586
  file /usr/lib/gstreamer-0.10/libgsty4menc.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.i586 conflicts with file from package gstreamer-plugins-good-0.10.15-4.fc11.i586

However, on a root console, the following works:

# yum install gstreamer-plugins-good gstreamer-plugins-bad
Loaded plugins: refresh-packagekit
Setting up Install Process
Package gstreamer-plugins-good-0.10.15-4.fc11.i586 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-bad.i586 0:0.10.13-6.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================================
 Package                                       Arch                         Version                                Repository                                      Size
========================================================================================================================================================================
Installing:
 gstreamer-plugins-bad                         i586                         0.10.13-6.fc11                         rpmfusion-free-updates                         1.1 M


Note that the version yum pulls in is newer than that which rhythmbox wants.
Installing gstreamer-plugins-bad-0.10.13-6.fc11 via yum works, and does not give any conflicts. I can also play AAC files now.

Comment 1 Mark Watts 2009-09-21 23:05:29 UTC
I should mention that rpmfusion-free contains the package that rhythmbox is trying to pull in:

# yum --showduplicates info gstreamer-plugins-bad
Loaded plugins: refresh-packagekit
Installed Packages
Name       : gstreamer-plugins-bad
Arch       : i586
Version    : 0.10.13
Release    : 6.fc11
Size       : 2.9 M
Repo       : installed
From repo  : rpmfusion-free-updates
Summary    : GStreamer streaming media framework "bad" plug-ins
URL        : http://gstreamer.freedesktop.org/
License    : LGPLv2+ and LGPLv2
Description: GStreamer is a streaming media framework, based on graphs of elements which
           : operate on media data.
           : 
           : This package contains plug-ins that have licensing issues, aren't tested
           : well enough, or the code is not of good enough quality.

Available Packages
Name       : gstreamer-plugins-bad
Arch       : i586
Version    : 0.10.11
Release    : 4.fc11
Size       : 1.2 M
Repo       : rpmfusion-free
Summary    : GStreamer streaming media framework "bad" plug-ins
URL        : http://gstreamer.freedesktop.org/
License    : LGPLv2+ and LGPLv2
Description: GStreamer is a streaming media framework, based on graphs of elements which
           : operate on media data.
           : 
           : This package contains plug-ins that have licensing issues, aren't tested
           : well enough, or the code is not of good enough quality.

Name       : gstreamer-plugins-bad
Arch       : i586
Version    : 0.10.13
Release    : 3.fc11
Size       : 1.1 M
Repo       : rpmfusion-free-updates
Summary    : GStreamer streaming media framework "bad" plug-ins
URL        : http://gstreamer.freedesktop.org/
License    : LGPLv2+ and LGPLv2
Description: GStreamer is a streaming media framework, based on graphs of elements which
           : operate on media data.
           : 
           : This package contains plug-ins that have licensing issues, aren't tested
           : well enough, or the code is not of good enough quality.

Name       : gstreamer-plugins-bad
Arch       : i586
Version    : 0.10.13
Release    : 6.fc11
Size       : 1.1 M
Repo       : rpmfusion-free-updates
Summary    : GStreamer streaming media framework "bad" plug-ins
URL        : http://gstreamer.freedesktop.org/
License    : LGPLv2+ and LGPLv2
Description: GStreamer is a streaming media framework, based on graphs of elements which
           : operate on media data.
           : 
           : This package contains plug-ins that have licensing issues, aren't tested
           : well enough, or the code is not of good enough quality.

Comment 2 Bastien Nocera 2009-09-22 11:17:32 UTC
That's probably because the repo isn't enable in PK. PK does the installation anyway, reassigning.

Comment 3 Richard Hughes 2009-09-22 14:01:16 UTC
I think this is fixed in rawhide, when I can boot my F11 VM I'll see if I can reproduce in F11.

Comment 4 Michal Schmidt 2009-12-01 08:57:38 UTC
I have a report from last week from an F11 user that the bug is still present.
PackageKit attepts to install an old version of gstreamer-plugins-bad, even when a newer one is available. This is bug 514879 (fixed in F12, but not in F11).

Comment 5 Richard Hughes 2010-03-23 09:37:07 UTC
I'm pretty sure we've got things nailed in F12 now. Please re-open if this isn't the case.


Note You need to log in before you can comment on or make changes to this bug.