Bug 524738 - setroubleshoot: SELinux is preventing the dbus-daemon from using potentially mislabeled files (root).
Summary: setroubleshoot: SELinux is preventing the dbus-daemon from using potenti...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:1d267f44bad...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 02:06 UTC by FAMM
Modified: 2009-09-22 02:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 02:56:13 UTC


Attachments (Terms of Use)

Description FAMM 2009-09-22 02:06:50 UTC
The following was filed automatically by setroubleshoot:

Resúmen:

SELinux is preventing the dbus-daemon from using potentially mislabeled files
(root).

Descripción Detallada:

SELinux has denied dbus-daemon access to potentially mislabeled file(s) (root).
This means that SELinux will not allow dbus-daemon to use these files. It is
common for users to edit files in their home directory or tmp directories and
then move (mv) them to system directories. The problem is that the files end up
with the wrong file context which confined applications are not allowed to
access.

Permitiendo Acceso:

If you want dbus-daemon to access this files, you need to relabel them using
restorecon -v 'root'. You might want to relabel the entire directory using
restorecon -R -v 'root'.

Información Adicional:

Contexto Fuente               system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Contexto Destino              system_u:object_r:admin_home_t:s0
Objetos Destino               root [ dir ]
Fuente                        dbus-daemon
Dirección de Fuente          /bin/dbus-daemon
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          dbus-1.2.16-4.fc12
Paquetes RPM Destinos         filesystem-2.4.27-1.fc12
RPM de Políticas             selinux-policy-3.6.26-8.fc12
SELinux Activado              True
Tipo de Política             targeted
MLS Activado                  True
Modo Obediente                Enforcing
Nombre de Plugin              home_tmp_bad_labels
Nombre de Equipo              (removed)
Plataforma                    Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.i686 #1 SMP Tue Aug
                              11 21:20:05 EDT 2009 i686 i686
Cantidad de Alertas           1
Visto por Primera Vez         lun 21 sep 2009 14:39:25 CDT
Visto por Última Vez         lun 21 sep 2009 14:39:25 CDT
ID Local                      bd72ee27-ece7-4c39-886c-619b66f26eb4
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1253561965.279:15): avc:  denied  { search } for  pid=1218 comm="dbus-daemon" name="root" dev=sda1 ino=261 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1253561965.279:15): arch=40000003 syscall=5 success=no exit=-13 a0=1316790 a1=98800 a2=1d9ff4 a3=1316790 items=0 ppid=1217 pid=1218 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t admin_home_t:dir search;

Comment 1 Daniel Walsh 2009-09-22 02:56:13 UTC
Please yum update to the latest OS.  Fixed in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.