Bug 524782 - Exception when running updates, error related with rhnplugin: can't set attribute
Exception when running updates, error related with rhnplugin: can't set attri...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-22 03:20 EDT by miguel galarraga
Modified: 2013-03-14 15:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 15:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump (1.41 KB, application/octet-stream)
2009-09-22 03:20 EDT, miguel galarraga
no flags Details

  None (edit)
Description miguel galarraga 2009-09-22 03:20:59 EDT
Created attachment 362033 [details]
crash dump

Description of problem: 
Exception ocurred when running updates or add/remove software. It also happens when running yum update. Problem seems to be related with rhnplugin
 
Component: pirut
Summary: TBefbd0369 rhnplugin.py:243:__init__:AttributeError: can't set attribute


Version-Release number of selected component (if applicable):
red hat el5.2

How reproducible:
trying to update

Steps to Reproduce:
1. run pup or yum update or

  
Actual results:
unhandled exception 

omponent: pirut
Summary: TBefbd0369 rhnplugin.py:243:__init__:AttributeError: can't set attribute

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 609, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 84, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 170, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 253, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 145, in init_hook
    repo = RhnRepo(channel)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 243, in __init__
    self.metadata_cookie = 'cookie'
AttributeError: can't set attribute

Local variables in innermost frame:
self: rhel-x86_64-client-5
channel: <up2date_client.rhnChannel.rhnChannel instance at 0x16fd7098>
urls: ['https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-client-5']

Expected results:
open pup interface
Comment 1 James Antill 2013-03-14 15:04:25 EDT
 Weird problem with the rhnplugin. It's probably fixed by now, as rhnplugin has changed significantly.

Note You need to log in before you can comment on or make changes to this bug.