Bug 52483 - CDROM kernel module not loaded at boot
Summary: CDROM kernel module not loaded at boot
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: roswell
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-24 04:57 UTC by William Shotts
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-29 19:38:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (4.61 KB, text/plain)
2001-08-24 04:59 UTC, William Shotts
no flags Details

Description William Shotts 2001-08-24 04:57:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
On my P200 machine, the ATAPI CDROM drive is not recognized after
installation of roswell (2).  I must manually load the cdrom kernel module
(for example, modprobe cdrom) for the driver to load.  System works with RH
7.1.  dmesg output is attached.  I notice that the IDE floppy driver is
loaded though it is not needed.  This differs from 7.1 behavior.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install roswell on affected machine
2.mount /mnt/cdrom (mount fails)
3.modprobe cdrom
4.mount /mnt/cdrom (mounts succeeds)
	

Additional info:

Comment 1 William Shotts 2001-08-24 04:59:37 UTC
Created attachment 29336 [details]
dmesg output

Comment 2 Glen Foster 2001-08-24 15:52:24 UTC
We (Red Hat) really need to fix this before next release.

Comment 3 Arjan van de Ven 2001-08-25 11:00:07 UTC
Strange. This works for me.

Comment 4 Michael K. Johnson 2001-08-25 12:42:08 UTC
I cannot reproduce it either on any hardware I have tried so far

Comment 5 Arjan van de Ven 2001-08-25 13:13:32 UTC
does running "depmod -ae" as root make the autoloading of ide-cd.o work again ?

Comment 6 William Shotts 2001-08-29 19:38:34 UTC
'depmod -ae' does fix the problem.

Comment 7 Arjan van de Ven 2001-09-03 17:35:02 UTC
depmod -ae is supposed to run at boot :(, _and_ at rpm -i time.


Note You need to log in before you can comment on or make changes to this bug.