Bug 524924 - jetty pulls in many other packages
Summary: jetty pulls in many other packages
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jetty
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 17:59 UTC by shmuel siegel
Modified: 2009-10-01 05:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 23:10:55 UTC


Attachments (Terms of Use)

Description shmuel siegel 2009-09-22 17:59:28 UTC
Description of problem:
jetty now pulls in netbeans and tomcat among other things. Why would jetty need these other packages? Isn't it kind of defeating the purpose of jetty for it to need tomcat?


Version-Release number of selected component (if applicable):
Rawhide as of 21 September
jetty-6.1.20-3.fc12

Comment 1 Andrew Overholt 2009-09-22 18:23:38 UTC
It doesn't pull in all of tomcat, it pulls in the APIs which are a sub-package of tomcat.  If you'd like to split them off into a separate package, I'm sure the tomcat maintainer would appreciate the help.

As for netbeans, I'm sure it doesn't pull it in.  Maybe you're seeing one of the netbeans sub-packages which is a dependency of another package?  If you could specify where you saw the word "netbeans" or just paste the entire yum transaction it would help.  Thanks.

Comment 2 shmuel siegel 2009-09-22 18:38:38 UTC
I agree that jetty isn't directly pulling in so many things but I was very surprised when an update to jetty required me to install 14 packages. Anyway, here is the transaction.


Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package jetty.noarch 0:6.1.20-3.fc12 set to be updated
--> Processing Dependency: slf4j for package: jetty-6.1.20-3.fc12.noarch
--> Processing Dependency: tomcat6-jsp-2.1-api for package: jetty-6.1.20-3.fc12.noarch
--> Processing Dependency: tomcat5 for package: jetty-6.1.20-3.fc12.noarch
--> Running transaction check
---> Package slf4j.noarch 0:1.5.8-5.fc12 set to be updated
---> Package tomcat5.noarch 0:5.5.27-7.4.fc12 set to be updated
--> Processing Dependency: tomcat5-common-lib = 5.5.27-7.4.fc12 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: tomcat5-server-lib = 5.5.27-7.4.fc12 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: tomcat5-server-lib = 5.5.27-7.4.fc12 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: tomcat5-common-lib = 5.5.27-7.4.fc12 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: jakarta-commons-daemon >= 1.0.1 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: jakarta-commons-collections-tomcat5 >= 3.1 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: jakarta-commons-daemon >= 1.0.1 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: jakarta-commons-pool-tomcat5 >= 1.2 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: jakarta-commons-dbcp-tomcat5 >= 1.2.1 for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: java-1.6.0-devel for package: tomcat5-5.5.27-7.4.fc12.noarch
--> Processing Dependency: /lib/lsb/init-functions for package: tomcat5-5.5.27-7.4.fc12.noarch
---> Package tomcat6-jsp-2.1-api.noarch 0:6.0.18-10.2.fc12 set to be updated
--> Running transaction check
---> Package jakarta-commons-collections-tomcat5.i686 0:3.2.1-3.fc12 set to be updated
---> Package jakarta-commons-daemon.i686 1:1.0.1-8.8.fc12 set to be updated
---> Package jakarta-commons-dbcp-tomcat5.noarch 0:1.2.1-13.7.fc12 set to be updated
---> Package jakarta-commons-pool-tomcat5.i686 0:1.3-12.5.fc12 set to be updated
---> Package java-1.6.0-openjdk-devel.i686 1:1.6.0.0-31.b16.fc12 set to be updated
--> Processing Dependency: netbeans-platform for package: 1:java-1.6.0-openjdk-devel-1.6.0.0-31.b16.fc12.i686
---> Package redhat-lsb.i686 0:3.2-5.fc12 set to be updated
---> Package tomcat5-common-lib.noarch 0:5.5.27-7.4.fc12 set to be updated
---> Package tomcat5-server-lib.noarch 0:5.5.27-7.4.fc12 set to be updated
--> Running transaction check
---> Package netbeans-platform.noarch 0:6.7.1-2.fc12 set to be updated
--> Processing Dependency: swing-layout >= 1.0 for package: netbeans-platform-6.7.1-2.fc12.noarch
--> Processing Dependency: javahelp2 >= 2.0.05 for package: netbeans-platform-6.7.1-2.fc12.noarch
--> Running transaction check
---> Package javahelp2.noarch 0:2.0.05-8.fc12 set to be updated
---> Package swing-layout.i686 0:1.0.3-4.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                             Arch   Version               Repository
                                                                           Size
================================================================================
Updating:
 jetty                               noarch 6.1.20-3.fc12         rawhide 1.1 M
Installing for dependencies:
 jakarta-commons-collections-tomcat5 i686   3.2.1-3.fc12          rawhide  59 k
 jakarta-commons-daemon              i686   1:1.0.1-8.8.fc12      rawhide  41 k
 jakarta-commons-dbcp-tomcat5        noarch 1.2.1-13.7.fc12       rawhide 107 k
 jakarta-commons-pool-tomcat5        i686   1.3-12.5.fc12         rawhide  84 k
 java-1.6.0-openjdk-devel            i686   1:1.6.0.0-31.b16.fc12 rawhide 8.7 M
 javahelp2                           noarch 2.0.05-8.fc12         rawhide 549 k
 netbeans-platform                   noarch 6.7.1-2.fc12          rawhide 2.8 M
 redhat-lsb                          i686   3.2-5.fc12            rawhide 255 k
 slf4j                               noarch 1.5.8-5.fc12          rawhide 144 k
 swing-layout                        i686   1.0.3-4.fc12          rawhide 138 k
 tomcat5                             noarch 5.5.27-7.4.fc12       rawhide 299 k
 tomcat5-common-lib                  noarch 5.5.27-7.4.fc12       rawhide  97 k
 tomcat5-server-lib                  noarch 5.5.27-7.4.fc12       rawhide 1.6 M
 tomcat6-jsp-2.1-api                 noarch 6.0.18-10.2.fc12      rawhide  70 k

Transaction Summary
================================================================================
Install      14 Package(s)
Upgrade       1 Package(s)

Total download size: 16 M
Is this ok [y/N]: Exiting on user Command
Complete!

Comment 3 Andrew Overholt 2009-09-22 18:55:15 UTC
Thanks for the whole transaction log.  Let's go through them one-by-one:

 jakarta-commons-collections-tomcat5 i686   3.2.1-3.fc12          rawhide  59 k

Is this in the output of "rpm -q --requires tomcat5"?

 jakarta-commons-daemon              i686   1:1.0.1-8.8.fc12      rawhide  41 k

This I think is an actual jetty dependency.

 jakarta-commons-dbcp-tomcat5        noarch 1.2.1-13.7.fc12       rawhide 107 k
 jakarta-commons-pool-tomcat5        i686   1.3-12.5.fc12         rawhide  84 k

Are these also brought in by the new tomcat?

 java-1.6.0-openjdk-devel            i686   1:1.6.0.0-31.b16.fc12 rawhide 8.7 M
 javahelp2                           noarch 2.0.05-8.fc12         rawhide 549 k

This is a dep. of netbeans-platform AFAIK.

 netbeans-platform                   noarch 6.7.1-2.fc12          rawhide 2.8 M

This is brought in by java-1.6.0-openjdk-devel for visualvm, I believe.

 redhat-lsb                          i686   3.2-5.fc12            rawhide 255 k

Obviously unrelated :)

 slf4j                               noarch 1.5.8-5.fc12          rawhide 144 k

This I think is an actual jetty dependency.

 swing-layout                        i686   1.0.3-4.fc12          rawhide 138 k

This is a dep. of netbeans-platform AFAIK.

 tomcat5                             noarch 5.5.27-7.4.fc12       rawhide 299 k
 tomcat5-common-lib                  noarch 5.5.27-7.4.fc12       rawhide  97 k
 tomcat5-server-lib                  noarch 5.5.27-7.4.fc12       rawhide 1.6 M

Are any of these in the output of "rpm -q --requires jetty"?

 tomcat6-jsp-2.1-api                 noarch 6.0.18-10.2.fc12      rawhide  70 k

This is I think the only package actually needed by jetty and is the API package I mention in comment #1.

Please try doing "yum install jetty" on a clean system and see what tomcat packages get brought in.

Comment 4 shmuel siegel 2009-09-23 09:58:10 UTC
I tried to install jetty onto a liveusb f12 alpha but the 170 meg download seemed to have killed the installation. So I tried to just update jetty on an f11 machine that I could afford to have problems. The output of "rpm -q --requires jetty" is as follows. Note: jetty requires tomcat5 which requires the other tomcat items and also java-1.6.0-openjdk-devel which, in turn, is bringing in netbeans-platform. So there is only one problem: why does jetty want tomcat5.

/bin/bash  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
ant >= 0:1.6
chkconfig  
classpathx-mail  
config(jetty) = 6.1.20-3.fc12
jakarta-commons-el  
jakarta-commons-logging  
jpackage-utils >= 0:1.6
jsp  
mx4j >= 0:3.0
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
shadow-utils  
shadow-utils  
slf4j  
tomcat5  
tomcat5-jasper  
tomcat5-jasper >= 5.5.26-1.5
tomcat6-jsp-2.1-api  
tomcat6-servlet-2.5-api  
xerces-j2 >= 0:2.7
xml-commons-apis  
rpmlib(PayloadIsXz) <= 5.2-1

Comment 5 Andrew Overholt 2009-09-23 12:24:32 UTC
Alex, do you know why jetty Requires tomcat5 itself?

Comment 6 Alexander Kurtakov 2009-09-29 08:35:27 UTC
Please check with http://koji.fedoraproject.org/koji/buildinfo?buildID=134130 . I think that there are no unwanted dependencies now.

Comment 7 shmuel siegel 2009-09-29 22:41:41 UTC
Much more reasonable. If this was intended it is good.

Dependency Installed:
  slf4j.noarch 0:1.5.8-5.fc12   tomcat6-jsp-2.1-api.noarch 0:6.0.18-10.2.fc12  

Updated:
  jetty.noarch 0:6.1.20-4.fc12

Comment 8 Alexander Kurtakov 2009-09-30 05:37:38 UTC
(In reply to comment #7)
> Much more reasonable. If this was intended it is good.
> 
> Dependency Installed:
>   slf4j.noarch 0:1.5.8-5.fc12   tomcat6-jsp-2.1-api.noarch 0:6.0.18-10.2.fc12  
> 
> Updated:
>   jetty.noarch 0:6.1.20-4.fc12  

Yes slf4j is the library jetty uses for logging and tomcat6-jsp-2.1-api is needed because jetty doesn't provide it's own implementation of the jsp api. 
If it's ok will you close the bug?

Comment 9 shmuel siegel 2009-09-30 23:10:55 UTC
I am closing this now since jetty.noarch 0:6.1.20-4.fc12 is now in rawhide.
One question though, jetty still requires tomcat5-jasper. Should it?

Comment 10 Alexander Kurtakov 2009-10-01 05:57:43 UTC
Yes jasper is the library used for jsp compilation. It is really needed.


Note You need to log in before you can comment on or make changes to this bug.