Bug 525 - info directory symlink broken in 5.2 install
info directory symlink broken in 5.2 install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: aboot (Show other bugs)
5.2
All Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-18 19:03 EST by Joe Harrington
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-23 11:25:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 1998-12-18 19:03:58 EST
This report is about the info package.  The info package
does not appear on the list of components on the "enter bug"
page of bugzilla, and it wouldn't let me go without a
component, so I picked the first one to make it happy.

The file /usr/info/dir should be a symlink to
../../etc/info-dir, according to the package.  Somehow
during a fresh RH5.2 installation, the symlink is broken and
the file is copied to /usr/info.  Other packages then append
to it.  The result is:

# ls -l /usr/info/dir /etc/info-dir
  11 -rw-r--r--   1 root     root        11145 Nov 25 17:19
/etc/info-dir
  17 -rw-r--r--   1 root     root        15890 Nov 25 17:26
/usr/info/dir

A diff shows only appends to the /usr/info/dir.  Since /usr
should be read-only, the symlink should be preserved.  rpm
-V info shows the following after a fresh 5.2 install:
info-3.12-9
S.5....T c /etc/info-dir
SM5....T c /usr/info/dir
Comment 1 David Lawrence 1998-12-23 10:31:59 EST
Verified and assigned.  When you do a default install, this is correct
so some packages in an everything install put data in /usr/info/dir.
Comment 2 Preston Brown 1999-03-23 11:25:59 EST
There was a bug in the psacct package which was messing up the
symlink.  This has been corrected as of psacct-6.3-9.  Installs of
later versions of Red Hat Linux will automatically rebuild this file
when info/texinfo are upgraded so the symlink problem will be
remedied.

Note You need to log in before you can comment on or make changes to this bug.