Bug 525078 - zlib API not LFS compatible
Summary: zlib API not LFS compatible
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: zlib
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 09:33 UTC by Andreas Schwab
Modified: 2010-01-29 08:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-29 08:43:26 UTC


Attachments (Terms of Use)

Description Andreas Schwab 2009-09-23 09:33:48 UTC
The zlib API in <zlib.h> contains a few functions that take or return z_off_t values.  This is incompatible with LFS, where z_off_t (which is defined as off_t) depends on _FILE_OFFSET_BITS.  Either z_off_t must be defined to a fixed type or the API must be extended to cover both _FILE_OFFSET_BITS=32 and _FILE_OFFSET_BITS=64.

Comment 1 Ivana Varekova 2010-01-29 08:43:26 UTC
The problem is fixed in upstream (from 1.2.3.4).


Note You need to log in before you can comment on or make changes to this bug.