Bug 52509 - Cannot configure sawfish.
Cannot configure sawfish.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 11:14 EDT by lars
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 13:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -qa on the system experiencing this bug. (9.66 KB, text/plain)
2001-08-27 12:08 EDT, lars
no flags Details

  None (edit)
Description lars 2001-08-24 11:14:06 EDT
Description of Problem:

Attempts to bring up the sawfish configuration tool from the "Start Here"
window result in the error message "Sawfish is not running."  I beg to differ:

$ ps -u lars | grep sawfish
1440 ?        00:00:36 sawfish

Version-Release number of selected component (if applicable):

sawfish-0.38-9
nautilus-1.0.4-34

How Reproducible:

See below.

Steps to Reproduce:
1. Open "start here" by clickingon the mushroom (?) button.
2. Double click on the "Preferences" icon.
3. Double click on the "Sawfish window manager" icon.
4. Double click on any of the settings categories.

The window that comes up says "sawfish isn't running."

Actual Results:


Expected Results:

You know, a configuration dialog or something.

Additional Information:
Comment 1 Glen Foster 2001-08-24 11:52:15 EDT
We (Red Hat) really need to fix this before next release.
Comment 2 Havoc Pennington 2001-08-24 13:57:08 EDT
Works on my test machine. If you log out and log back in, does it work again?
Comment 3 Havoc Pennington 2001-08-27 12:03:08 EDT
I can't reproduce, if logging out solves it most likely it was some random bogon
that won't happen again, if not then please attach the files in ~/.sawfish (or
put them up for http/ftp maybe?) and it might help reproduce...
Comment 4 lars 2001-08-27 12:07:40 EDT
Logging out and back in does not solve the problem.  This is a pretty vanilla
system; I haven't made any GUI-related configuration changes at all.  There is
nothing in ~/.sawfish but files in the "sessions" directory, which all consist
of the following:

  ;; session saved for lars@localhost.localdomain
  ;; sawfish version 0.38; Wed Aug 22 06:19:46 2001

So there's really nothing to attach.

I will, just for kicks, attach the output of 'rpm -qa'.
Comment 5 lars 2001-08-27 12:08:59 EDT
Created attachment 29718 [details]
Output of rpm -qa on the system experiencing this bug.
Comment 6 Havoc Pennington 2001-08-28 14:34:50 EDT
Asked on internal mailing lists if anyone saw this problem, I can't find anyone
who can trigger this bug. There must be something weird going on...

Anything suspicious in ~/.xsession-errors?
Comment 7 Havoc Pennington 2004-11-03 13:36:42 EST
Closing ancient bugs

Note You need to log in before you can comment on or make changes to this bug.