Bug 525173 - Audacious workspace preferences should sync with window manager
Summary: Audacious workspace preferences should sync with window manager
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 15:19 UTC by Christopher Beland
Modified: 2010-06-10 09:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-19 10:39:40 UTC


Attachments (Terms of Use)

Description Christopher Beland 2009-09-23 15:19:39 UTC
I recently had some trouble getting Audacious to behave as I wanted it to.  It seemed like it was forgetting which workspaces it should show up on every time it was restarted, but it was pointed out to me that Audacious has a preference for this which can be set manually (and which I had apparently changed at some point in the distant past).  The problem was that this is not coordinated with a similar interface in the Gnome Window List. It's easy to send the application mixed signals and be confused (and frustrated) that it doesn't behave consistently.

Here is a sequence of changes, describing how the application currently behaves vs. how I think it should behave:

* Start Audacious with default settings.  Shows up on the workspace I started it from.
* Select "Always on Visible Workspace" from Window List.  Audacious shows up on all workspaces.
* Close and restart Audacious; only shows up on the workspace I started it from.  Should have showed up on all workspaces.
* Right-click on Audacious, select View -> Put on All Workspaces.
* Close and restart Audacious; appears on all workspaces.
* Select "Move to Another Workspace -> Audio" in Window List.  Moved to selected workspace.
* Close and restart Audacious; appears on all workspaces.  Should have appeared only on one workspace.
* Select "Only on This Workspace" in Window List.  Appears only on current workspace.
* Close and restart Audacious; appears on all workspaces.  Should have appeared only on one workspace.

Version: audacious-1.5.1-11.fc11.i586

Comment 1 Michael Schwendt 2009-09-23 16:05:25 UTC
Why do you request a _feature request_ here and for Audacious 1.5.1 if Fedora 12 development contains Audacious 2.1 (and upstream has published Audacious 2.2-alpha1)?

So, can you still reproduce this with 2.1 or 2.2-alpha1? Have you filed a feature request in upstream's tracker?

Comment 2 Christopher Beland 2009-09-23 18:52:14 UTC
I have not filed a report upstream. Whether this is a usability bug or a potential usability feature is a matter of semantics, I guess. From this documentation:

https://fedoraproject.org/wiki/Bugs_and_feature_requests#Enhancement_Requests

and my experience, both bug reports and feature requests are welcome and encouraged from all supported Fedora releases. It's my understanding that end users and testers are not expected to be aware of upstream activities.  For example, when we triage, looking for upstream bug reports is optional, and it's explicitly left up to package maintainers to decide whether to patch the version in the supported release, make a change in upstream code and tell users to wait for the next release, file a bug upstream and hope for a change from other developers, or decide the suggestion is a bad idea.  See:

https://fedoraproject.org/wiki/BugZappers/How_to_Triage#Optional_steps

I attempted to reproduce this in Rawhide, but the latest daily build (desktop-i386-20090921.16.iso) would not boot, either in QEMU or as a LiveUSB.

Comment 3 Michael Schwendt 2009-10-19 10:39:40 UTC
That Wiki page refers to distribution development, not application development. We don't have the resources to let packagers maintain lots of feature requests that ought to be submitted in upstream trackers.

Bug reports are something entirely different.

I've forwarded this ticket here: http://jira.atheme.org/browse/AUD-73
Also see: https://bugzilla.redhat.com/page.cgi?id=fields.html#status

Comment 4 Michael Schwendt 2009-10-27 13:19:39 UTC
"window-state-event" support has been committed to upstream cvs after 2.2-beta1.

Comment 5 Michael Schwendt 2010-06-10 09:06:00 UTC
Pulled again upstream because it causes problems with several wms.


Note You need to log in before you can comment on or make changes to this bug.