Bug 52534 - WGet cannot work with socks5-v1.0r11
Summary: WGet cannot work with socks5-v1.0r11
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wget   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-24 19:02 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 21:14:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Socksv5 fix for wget (32.85 KB, patch)
2001-08-24 19:04 UTC, Need Real Name
no flags Details | Diff
Pgp Signature for the patch (494 bytes, text/plain)
2001-08-24 19:11 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-08-24 19:02:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
WGet cannot penetrate to the outside world through a socks firewall if 
socks5-v1.0r11 libraries are installed.

socks5-v1.0r11 changed the names of its library routines. I posted a fix-
patch to wget@sunsite.dk and to bug-wget@gnu.org

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up wget
2. type wget www.redhat.com
3.
	

Actual Results:  no path to host

Expected Results:  subdirectory named www.redhat.com that contains the 
retreived information

Additional info:

Comment 1 Need Real Name 2001-08-24 19:04:16 UTC
Created attachment 29397 [details]
Socksv5 fix for wget

Comment 2 Need Real Name 2001-08-24 19:11:43 UTC
Created attachment 29398 [details]
Pgp Signature for the patch

Comment 3 Trond Eivind Glomsrxd 2001-08-26 21:14:38 UTC
We don't include socks support at all, do we?


Comment 4 Trond Eivind Glomsrxd 2001-08-31 20:35:11 UTC
The apatch should be submitted to the wget maintainers.

I'll add this after the next release in order to make recompile simpler for
those desiring it.


Note You need to log in before you can comment on or make changes to this bug.