Bug 525383 - F12 Alpha: nVidia nForce PATA: install succeeds, but installed kernel lacks P-ATA driver
Summary: F12 Alpha: nVidia nForce PATA: install succeeds, but installed kernel lacks P...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 07:22 UTC by Manfred Knick
Modified: 2009-11-05 14:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-05 14:25:27 UTC
Type: ---


Attachments (Terms of Use)

Description Manfred Knick 2009-09-24 07:22:37 UTC
MoBo: ASUS ALiveDual-eSATA2 with onboard nVidia nForce3 250
Disk: P-ATA on Primary Master

Installing from Fedora-12 Alpha x86_64 DVD succeeds without problems;
afterwards, booting fails with
. . . "VFS: Cannot open root device ... or unknown-block(0,0)"
. . . Please append a correct "root=" boot option;
. . . . . . . . . . here are the available partitiopns:
. . . Kernel panic - not syncing: VFS:
. . . . . . . . . . Unable to mount root fs on unknown-block(0,0)

To me, this seems to indicate that the instlled kernel
. . . vmlinuz-2.6.31-33.fc12.x86_64
lacks support for the onboard P-ATA controller.

The installed corresponding /boot/config--2.6.31-33.fc12.x86_64 includes
. . . CONFIG_SATA_NV=m
. . . CONFIG_PATA_AMD=m


Unfortunately, this makes it hard for non-experienced uses to overcome
because by-passing would involve
either
- chroot from a (64-bit) RescueCd into this installed system
- download a Full Source 2.6.31 Kernel e.g. from ww.kernel.org
- install / build / grub ...
- - - (all from the chroot command line)
or
- install another S-ATA drive disk into the box
- install this alpha to this S-ATA disk,
- download / build kernel with P-ATA support
- move it to the P-ATA /boot partition
- adapt grub

NOTABENE:
Install of Fedora 11 upon P-ATA has worked o.k. already.

Comment 1 Manfred Knick 2009-09-24 10:14:33 UTC
Another by-pass:
- download and build 2.6.31 on (hopefully still existing) Fedora 11 partitions
- cp (or scp) from
- - /boot
- - /usr/src
- - /usr/lib

Take care:
- Don't _copy_ the links in /usr/lib; create them a-new
- you need to configure the (old-style) initrd in grub config
- - because of that, your terminal settings might not match

Afterwards, at least you can boot / configure / yum update +  upgrade :)

HTH.

Comment 2 Chuck Ebbert 2009-09-24 14:41:13 UTC
The kernel has support, but dracut isn't loading the driver, or isn't scanning the disks properly.

Comment 3 Manfred Knick 2009-09-25 11:11:08 UTC
Positive news - just to confirm:

Today, after upgrading, the new kernel-build boots flawlessly:

. . . # uname -a
. . . . . Linux sid.maknit-int.de 2.6.31-40.fc12.x86_64 #1 SMP 
. . . . . Wed Sep 23 17:38:14 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

and the intermediately needed vanilla sources can be removed again.

Thanks!

Thus, it can be expected that with the next RC,
people will not suffer from this problem any more.

Kind regards
Manfred

Comment 4 Harald Hoyer 2009-11-05 12:17:46 UTC
this was kexec-tools, which prevented the build of a correct initramfs

Comment 5 Manfred Knick 2009-11-05 12:34:27 UTC
(In reply to comment #4)

> ... was ...

Does this mean that the issue is solved for upcoming final?

IFF "yes"
     { feel free to close my bug }

Comment 6 Neil Horman 2009-11-05 14:25:27 UTC
if you update to the latest kexec-tools, and the problem goes away, yes :) (-25 or later)


Note You need to log in before you can comment on or make changes to this bug.