Bug 525393 - MRG 1.2 ibm-prtmd userspace update
Summary: MRG 1.2 ibm-prtmd userspace update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities
Version: 1.2
Hardware: x86_64
OS: All
low
medium
Target Milestone: 1.2
: ---
Assignee: Clark Williams
QA Contact: David Sommerseth
URL:
Whiteboard:
Depends On:
Blocks: 527551
TreeView+ depends on / blocked
 
Reported: 2009-09-24 08:10 UTC by IBM Bug Proxy
Modified: 2016-05-22 23:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
RT Enhancement ibm-prtmd has been updated and now contains fixes for the IBM BladeCenter LS21, LS22, HS21XM, and Intel Core i7 Processor.
Clone Of:
Environment:
Last Closed: 2009-12-03 09:11:43 UTC


Attachments (Terms of Use)
updated ibm-prtm package (9.20 KB, application/x-bzip)
2009-10-08 11:10 UTC, IBM Bug Proxy
no flags Details
Updated /sbin/ibm-prtmd (19.28 KB, text/plain)
2009-10-23 22:40 UTC, IBM Bug Proxy
no flags Details
ibm-prtm-1.1.4.tar.bz2 (9.32 KB, application/octet-stream)
2009-10-26 17:30 UTC, IBM Bug Proxy
no flags Details
new ibm-prtm release 1.1.5 (9.42 KB, application/octet-stream)
2009-11-02 18:51 UTC, IBM Bug Proxy
no flags Details
1.1.5 is now 1.5 (9.42 KB, application/octet-stream)
2009-11-02 21:32 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1631 normal SHIPPED_LIVE Red Hat Enterprise MRG RT bug fix and enhancement update 2009-12-03 09:11:31 UTC
IBM Linux Technology Center 56332 None None None Never

Description IBM Bug Proxy 2009-09-24 08:10:44 UTC
=Comment: #0=================================================
KEITH MANNTHEY <kmannth@us.ibm.com> - 
There are a few needed changes for MRG 1.2 in ibm-prtmd. 

LS21/LS22 fix
I7core fix
Hs21xm fix

There are 3 small changes needed to properly support the new kernel. It will be next week before I
can finish testing all the platforms with MRG 1.2 beta code and deliver a single userspace update.

Comment 1 IBM Bug Proxy 2009-10-08 11:10:53 UTC
Created attachment 364084 [details]
updated ibm-prtm package


------- Comment on attachment From gowrishankar.m@in.ibm.com 2009-10-08 07:04 EDT-------


Attached the updated tarball of ibm-prtm.
Tested on relevant platforms for which the defect was filed.

Please consider the tarball for the fix.

Comment 2 Luis Claudio R. Goncalves 2009-10-13 15:07:04 UTC
Is there any difference on the userspace code for v1 and v2? I ask that because
similar changes, or at least part of it, was added to ibm-prtmd in the fixes of
BZ522359.

Comment 3 IBM Bug Proxy 2009-10-14 05:30:59 UTC
------- Comment From gowrishankar.m@in.ibm.com 2009-10-14 01:26 EDT-------
Attached tarball already has the fix as in BZ522359, plus few changes for
LS21 and LS22 edac classes. More on that, it also includes minor
correction on Makefile and modprobe.ibm-amd for 2.6.31 kernel series.

Adding patch header:
Signed-off-by: Keith Mannthey <kmannth@us.ibm.com>
Signed-off-by: Gowrishankar <gowrishankar.m@in.ibm.com>

Comment 4 Clark Williams 2009-10-14 20:22:31 UTC
the attached tarball is versioned ibm-prtm-1.1.1.tar.bz. We shipped ibm-prtm-1.2 back in September, which was the previous 1.1.1 with a patch from keith for i7core_edac. 

Is the attached ibm-prtm-1.1.1.tar.bz2 what I should consider ibm-prtm-1.3?

Comment 5 IBM Bug Proxy 2009-10-15 01:50:49 UTC
------- Comment From gowrishankar.m@in.ibm.com 2009-10-14 21:46 EDT-------
(In reply to comment #9)
> the attached tarball is versioned ibm-prtm-1.1.1.tar.bz. We shipped
> ibm-prtm-1.2 back in September, which was the previous 1.1.1 with a patch from
> keith for i7core_edac.
>
> Is the attached ibm-prtm-1.1.1.tar.bz2 what I should consider ibm-prtm-1.3?
>

Apologies  for the wrong versioning. Please consider it as ibm-prtm-1.3 .

Thanks.

Comment 6 IBM Bug Proxy 2009-10-23 22:40:48 UTC
Created attachment 365905 [details]
Updated /sbin/ibm-prtmd


------- Comment on attachment From kmannth@us.ibm.com 2009-10-23 18:35 EDT-------


Do you want a tar ball package?

Comment 7 Clark Williams 2009-10-24 14:08:30 UTC
Yes, please put together an ibm-prtm-1.4.tar.bz2 tarball and I'll put a new version of it out on the MRG repo.

Comment 8 IBM Bug Proxy 2009-10-26 17:30:49 UTC
Created attachment 366130 [details]
ibm-prtm-1.1.4.tar.bz2


------- Comment on attachment From kmannth@us.ibm.com 2009-10-26 13:26 EDT-------


This is the updated 1.4 tar ball.

Comment 9 IBM Bug Proxy 2009-10-26 18:41:15 UTC
------- Comment From kmannth@us.ibm.com 2009-10-26 14:32 EDT-------
Just to be clear.  The v1.4 will work on both MRG 1.1 and MRG 1.2.

Comment 10 IBM Bug Proxy 2009-10-30 00:41:12 UTC
------- Comment From kmannth@us.ibm.com 2009-10-29 20:36 EDT-------
ibm-prtm-1.4-1.el5rt contains the correct code and tested well.Thanks for picking up the changes.

Comment 11 IBM Bug Proxy 2009-11-02 18:51:07 UTC
Created attachment 367180 [details]
new ibm-prtm release 1.1.5


------- Comment on attachment From kmannth@us.ibm.com 2009-11-02 13:42 EDT-------


This can also be dowloaded from 

svn co https://ibm-prtm.svn.sourceforge.net/svnroot/ibm-prtm ibm-prtm

The svn logs is pretty new but it contains the correct code. 

ibm-prtm (1.5)
  * Fixed up module loading blacklist issue
  * Fixed broken version string
-- Keith Mannthey <kmannth@us.ibm.com> Nov 2, 2009

(and updated the CHANGELOG also)

Comment 12 IBM Bug Proxy 2009-11-02 21:32:22 UTC
Created attachment 367213 [details]
1.1.5 is now 1.5 


------- Comment on attachment From kmannth@us.ibm.com 2009-11-02 16:25 EDT-------


Same bits new version name.

Comment 13 David Sommerseth 2009-11-24 17:56:07 UTC
[root@hs21xm-2 log]# rpm -q ibm-prtm
ibm-prtm-1.5-1.el5rt
[root@hs21xm-2 log]# ibm-prtmd --version
Version is 1.5
[root@hs21xm-2 log]# service ibm-prtm start
IBM Real-Time HW Daemon: BIOS Real-Time module loaded.
IBM Real-Time HW Daemon: BMC unable to enter Real-Time Mode.
IBM Real-Time HW Daemon: Power capping, acoustical mode and some power configurations
IBM Real-Time HW Daemon: may not be supported.  Please check your system
IBM Real-Time HW Daemon: configuration for proper setup.
[root@hs21xm-2 ~]# dmesg | tail
EDAC MC: Removed device 0 for i5000_edac.c I5000: DEV 0000:00:10.0
EDAC MC: Ver: 2.1.0 Nov 16 2009
EDAC MC0: Giving out device to 'i5000_edac.c' 'I5000': DEV 0000:00:10.0
EDAC PCI0: Giving out device to module 'i5000_edac' controller 'EDAC PCI controller': DEV '0000:00:10.0' (POLLED)
ipmi message handler version 39.1
IPMI System Interface driver.
ipmi_si: Trying SMBIOS-specified kcs state machine at i/o address 0xc28, slave address 0x20, irq 0
ipmi: Found new BMC (man_id: 0x000002,  prod_id: 0x0081, dev_id: 0x20)
IPMI kcs interface initialized
ipmi device interface
[root@hs21xm-2 ~]# cd /var/log/
[root@hs21xm-2 log]# tail messages -n15
Nov 24 11:15:18 hs21xm-2 dhclient: DHCPACK from 10.15.4.11
Nov 24 11:15:18 hs21xm-2 dhclient: bound to 10.15.4.133 -- renewal in 14843 seconds.
Nov 24 11:51:14 hs21xm-2 ntpd[4262]: can't open /etc/ntp/drift.TEMP: Permission denied
Nov 24 11:51:16 hs21xm-2 yum: Updated: ibm-prtm-1.5-1.el5rt.noarch
Nov 24 11:52:30 hs21xm-2 IBM Real-Time HW Daemon: BIOS Real-Time module loaded.
Nov 24 11:52:31 hs21xm-2 kernel: ipmi message handler version 39.1
Nov 24 11:52:31 hs21xm-2 kernel: IPMI System Interface driver.
Nov 24 11:52:31 hs21xm-2 kernel: ipmi_si: Trying SMBIOS-specified kcs state machine at i/o address 0xc28, slave address 0x20, irq 0
Nov 24 11:52:31 hs21xm-2 kernel: ipmi: Found new BMC (man_id: 0x000002,  prod_id: 0x0081, dev_id: 0x20)
Nov 24 11:52:31 hs21xm-2 kernel: IPMI kcs interface initialized
Nov 24 11:52:31 hs21xm-2 kernel: ipmi device interface
Nov 24 11:52:31 hs21xm-2 IBM Real-Time HW Daemon: BMC unable to enter Real-Time Mode.
Nov 24 11:52:31 hs21xm-2 IBM Real-Time HW Daemon: Power capping, acoustical mode and some power configurations
Nov 24 11:52:31 hs21xm-2 IBM Real-Time HW Daemon: may not be supported.  Please check your system
Nov 24 11:52:31 hs21xm-2 IBM Real-Time HW Daemon: configuration for proper setup.
[root@hs21xm-2 log]# 

Smoke test seems to be good.

Comment 14 IBM Bug Proxy 2009-11-24 21:21:12 UTC
------- Comment From kmannth@us.ibm.com 2009-11-24 16:19 EDT-------
There is some issue with the BMC not entering the mode.  The FW support is there but the BMC is not allowing the service to start.

There are many possible reasons for this.  Acoustical mode or certain capping power policies at the blade center level can cause this.  Make sure you have all your power supplies plugged in as well.

We are working on a way to better deal with this error.  It is a little hard to sort out the "why" of this issue.

Comment 15 David Sommerseth 2009-11-25 08:32:56 UTC
(In reply to comment #14)
> ------- Comment From kmannth@us.ibm.com 2009-11-24 16:19 EDT-------
> There is some issue with the BMC not entering the mode.  The FW support is
> there but the BMC is not allowing the service to start.
> 
> There are many possible reasons for this.  Acoustical mode or certain capping
> power policies at the blade center level can cause this.  Make sure you have
> all your power supplies plugged in as well.
> 
> We are working on a way to better deal with this error.  It is a little hard to
> sort out the "why" of this issue.  

I did notice, but also forgot to mention it, that it did not really start on this particular piece of hardware.  The reason for moving it to VERIFIED was simply that the user-space side of ibm-prtm seemed to do it's job.  It loaded the needed modules, and tried to set everything properly up.

From that point of view, I concluded the software did it's best and failed due to some HW artefacts and that I did not have access to the proper HW for this to work flawlessly.  In addition, it was no regression compared against the currently available version 1.2-1.  Therefore the bug was moved to VERIFIED, indicating it is ready to be shipped.

If this is wrong, please notify me before the end of 2009-Nov-25 (EDT), and I'll revoke the VERIFIED status.

Retested it on another HW available today, an LS21 blade, with success:
[root@ls21-1 ~]# rpm -q ibm-prtm
ibm-prtm-1.5-1.el5rt
[root@ls21-1 ~]# ibm-prtmd --version
Version is 1.5
[root@ls21-1 ~]# service ibm-prtm start
IBM Real-Time HW Daemon: BIOS Real-Time module loaded.
IBM Real-Time HW Daemon: System Management Interrupts have been disabled to
IBM Real-Time HW Daemon: allow this system to run in Real-Time Mode.
[root@ls21-1 ~]# service ibm-prtm status
ibm-prtmd (pid  3009) is running...
[root@ls21-1 ~]# dmesg | tail -n 10
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
eth0: no IPv6 routers present
ipmi message handler version 39.1
IPMI System Interface driver.
ipmi_si: Trying SMBIOS-specified kcs state machine at i/o address 0xca8, slave address 0x20, irq 0
ipmi: Found new BMC (man_id: 0x000002,  prod_id: 0x0010, dev_id: 0x20)
IPMI kcs interface initialized
ipmi device interface
[root@ls21-1 ~]# tail /var/log/messages
Nov 25 02:28:40 ls21-1 IBM Real-Time HW Daemon: BIOS Real-Time module loaded.
Nov 25 02:28:40 ls21-1 kernel: ipmi message handler version 39.1
Nov 25 02:28:40 ls21-1 kernel: IPMI System Interface driver.
Nov 25 02:28:40 ls21-1 kernel: ipmi_si: Trying SMBIOS-specified kcs state machine at i/o address 0xca8, slave address 0x20, irq 0
Nov 25 02:28:40 ls21-1 kernel: ipmi: Found new BMC (man_id: 0x000002,  prod_id: 0x0010, dev_id: 0x20)
Nov 25 02:28:40 ls21-1 kernel: IPMI kcs interface initialized
Nov 25 02:28:41 ls21-1 kernel: ipmi device interface
Nov 25 02:28:41 ls21-1 IBM Real-Time HW Daemon: System Management Interrupts have been disabled to
Nov 25 02:28:41 ls21-1 IBM Real-Time HW Daemon: allow this system to run in Real-Time Mode.
[root@ls21-1 ~]#

Comment 16 Lana Brindley 2009-12-01 00:24:44 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
RT Enhancement

ibm-prtmd has been updated and now contains fixes for the IBM BladeCenter 
LS21, LS22, HS21XM, and Intel Core i7 Processor.

Comment 18 errata-xmlrpc 2009-12-03 09:11:43 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1631.html


Note You need to log in before you can comment on or make changes to this bug.