Bug 525403 - Back-port 8.70 to Fedora 10
Summary: Back-port 8.70 to Fedora 10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 524818 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 09:18 UTC by Robert Barre
Modified: 2009-10-21 00:48 UTC (History)
1 user (show)

Fixed In Version: 8.70-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-21 00:48:54 UTC


Attachments (Terms of Use)

Description Robert Barre 2009-09-24 09:18:26 UTC
Description of problem:
When I start gs -dBATCH -dNOPAUSE -sDEVICE=pnggray -r200x200 -sDither=floyd -sOutputFile=x%03d.png PDF.pdf 

Version-Release number of selected component (if applicable): 8.63


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
   **** File has an unbalanced >> (close dictionary).
   **** Incorrect object count in object stream.
Error: /rangecheck in resolveobjectstream
Operand stack:
   PageCount   178922   12   105   --dict:7/15(L)--   25   --nostringval--   false   --nostringval--   --dict:5/5(L)--   --dict:4/4(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --nostringval--   Contents   --nostringval--   MediaBox   --nostringval--   Parent   --nostringval--      Resources   --dict:2/2(L)--   Type   Page   --dict:5/5(L)--   --dict:3/3(L)--   --dict:4/4(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:4/4(L)--   --dict:5/5(L)--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1905   1   3   %oparray_pop   1904   1   3   %oparray_pop   1888   1   3   %oparray_pop   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1151/1684(ro)(G)--   --dict:1/20(G)--   --dict:75/200(L)--   --dict:75/200(L)--   --dict:106/127(ro)(G)--   --dict:275/300(ro)(G)--   --dict:20/25(L)--
Current allocation mode is local
GPL Ghostscript 8.63: Unrecoverable error, exit code 1


Expected results: On Fedora 11 on v8.70 it's OK
I have the following output 
Processing pages 1 through 21.
Page 1
Substituting font Times-Roman for FAAAAA+Times-Roman.
Can't find (or can't open) font file /usr/share/ghostscript/8.70/Resource/Font/NimbusRomNo9L-Regu.
Can't find (or can't open) font file NimbusRomNo9L-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/8.70/Resource/Font/NimbusRomNo9L-Regu.
Can't find (or can't open) font file NimbusRomNo9L-Regu.
Querying operating system for font files...
Loading NimbusRomNo9L-Regu font from /usr/share/fonts/default/Type1/n021003l.pfb... 3252356 1912729 6945696 5622683 3 done.
Substituting font Times-Roman for JAAAAA+Times-Roman.
Substituting font Times-Roman for NAAAAA+Times-Roman.
Substituting font Times-Roman for RAAAAA+Times-Roman.
Substituting font Times-BoldItalic for VAAAAA+Times-BoldItalic.
Loading NimbusRomNo9L-MediItal font from /usr/share/fonts/default/Type1/n021024l.pfb... 3396460 2057172 7260472 5920146 3 done.
Substituting font Times-Bold for ABAAAA+Times-Bold.
Loading NimbusRomNo9L-Medi font from /usr/share/fonts/default/Type1/n021004l.pfb... 3603980 2252536 7455224 6109377 3 done.
Substituting font Times-Bold for EBAAAA+Times-Bold.
Substituting font Times-Bold for IBAAAA+Times-Bold.
Substituting font Times-Bold for MBAAAA+Times-Bold.
Substituting font Times-Bold for RBAAAA+Times-Bold.
Loading NimbusSanL-Bold font from /usr/share/fonts/default/Type1/n019004l.pfb... 3745892 2401866 7534888 5742870 3 done.
Substituting font Helvetica for YBAAAA+Helvetica.
Loading NimbusSanL-Regu font from /usr/share/fonts/default/Type1/n019003l.pfb... 3766256 2175512 7568168 5698911 3 done.
Substituting font Helvetica for LG08R.
Substituting font Helvetica for LG08SIRET.
Page 2
etc....


Additional info:
Porting v8.70 on fedora 10 will solve my problem

Comment 1 Tim Waugh 2009-10-01 16:58:18 UTC
Please confirm which version is working for you on Fedora 11 (which has ghostscript-8.64 as the latest available version).

Comment 2 Tim Waugh 2009-10-01 16:58:58 UTC
*** Bug 524818 has been marked as a duplicate of this bug. ***

Comment 3 Robert Barre 2009-10-05 09:32:47 UTC
The version on Fedora 11 is 8.70.
It works like a charm on that version

Comment 4 Fedora Update System 2009-10-05 13:24:56 UTC
ghostscript-8.70-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ghostscript-8.70-1.fc10

Comment 5 Fedora Update System 2009-10-06 10:10:07 UTC
ghostscript-8.70-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10284

Comment 6 Tim Waugh 2009-10-19 12:46:35 UTC
Does this update work for you?

Comment 7 Robert Barre 2009-10-19 13:22:08 UTC
Yes thanks 
It worked

Comment 8 Fedora Update System 2009-10-21 00:48:49 UTC
ghostscript-8.70-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.