Bug 52542 - Install guide give wrong advice for LILO with Windows NT.
Install guide give wrong advice for LILO with Windows NT.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
http://www.redhat.com/support/manuals...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 16:20 EDT by Cynthia Higginbotham
Modified: 2014-08-04 18:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 17:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cynthia Higginbotham 2001-08-24 16:20:02 EDT
Description of Problem:

On page
http://www.redhat.com/support/manuals/RHL-7.1-Manual/install-guide/s1-guimode-lilo-conf.html
The Install Guide says " If you have Windows NT (and you want to install
LILO) you should choose to install LILO on the first sector of the root
partition, and not on the MBR. Please be sure to create a boot disk. In
this case, you will either need to use the boot disk, or configure the NT
system loader to boot LILO from the first sector of the root partition."

THIS IS WRONG. You should install LILO on the MBR just like you would for
Windows 9x, and set up your Windows NT boot partition in LILO exactly as
you would a Windows 9X boot partition, and it will work fine. Your install
guide makes it unnecessarily onerous to install Linux with NT, and seems to
be based on the equally erroneous old Linux+WinNT How-To. I have installed
both Debian Linux and RedHat Linux 7.1 (at different times) on an NT
system; worked fine.  I'm running Windows NT 4.0, Svc Pack 5 on the NT
side; no boot loader problems whatsoever.

Version-Release number of selected component (if applicable):
rhl-ig-x86(EN)-7.1-HTML-RHI (2001-03-14T12:41-0500)

How Reproducible:

Boots every damn time.

Steps to Reproduce:
1. Starting with an NT system with an unused partition, install RHL
normally. Install LILO on MBR.
2. Configure your Linux image & "Other" (Windows NT) boot partition in
lilo.conf normally. Run /sbin/lilo
3. Re-boot.
4. Select NT system at LILO boot menu

Actual Results:

NT boots normally.

Expected Results:

NT boots normally.

Additional Information:
Comment 1 Johnray Fuller 2001-08-28 16:02:29 EDT
moving bug to install guide...
Comment 2 Sandra Moore 2001-09-14 10:58:55 EDT
Hi -- Thanks for writing and for your feedback. Our support department has seen
some cases (mostly hardware dependent) where LILO and Win NT do not play well
together. Because of these cases, we have made the decision to keep some of the
warnings there for those who need them. However, as the Red Hat Linux distro
continues to improve, hopefully these cases will continue to become smaller in
number. However, I am glad to hear your test of this was a great success. 

Thanks again for the feedback and for your interest in Red Hat Linux.

Note You need to log in before you can comment on or make changes to this bug.