Bug 525442 - "Caps Lock is on." warning on the password screen when doing vnc installation
Summary: "Caps Lock is on." warning on the password screen when doing vnc installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tigervnc
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: alpha
: ---
Assignee: Adam Tkac
QA Contact:
URL:
Whiteboard:
: 527977 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 12:14 UTC by Jan Stodola
Modified: 2013-04-30 23:44 UTC (History)
8 users (show)

Fixed In Version: tigervnc-1.0.90-0.1.20100115svn3945.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-22 09:16:24 UTC


Attachments (Terms of Use)
screenshot (117.08 KB, image/png)
2009-09-24 12:14 UTC, Jan Stodola
no flags Details

Description Jan Stodola 2009-09-24 12:14:52 UTC
Created attachment 362479 [details]
screenshot

Description of problem:
On the screen for entering password is warning "Caps Lock is on." and there is no way how to turn it off (see screenshot). This is only when doing vnc installation on ppc64 arch, GUI installation does not have this issue.

Version-Release number of selected component (if applicable):
RHEL6.0-20090923.2, anaconda-12.29-1, ppc64, vnc installation
TigerVNC Viewer for X version 0.0.91 - built Aug 14 2009 09:54:10

How reproducible:
always

Steps to Reproduce:
1. start vnc installation
   for example: boot kernel+initrd with installer from previously installed F11
   add "vnc" boot option
2. use vncviever to connect and continue with the installation
3. on the password screen see warning
  
Actual results:
"Caps Lock is on." warning, no matter what the state of CapsLock is. (switching caps lock on installed system or remote system has no effect)

Expected results:
no warning is shown when caps lock is off

Comment 1 RHEL Product and Program Management 2009-09-24 12:28:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Chris Lumens 2009-10-08 13:32:54 UTC
*** Bug 527977 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2009-10-08 14:37:56 UTC
The problem here is that Xvnc does not support the Xkb extension, therefore XkbGetState is returning the state variable we gave it unmodified, which just so happens to have a 1 in the right slot.  I can make it so we clear this variable out before calling XkbGetState so the lack of a caps lock message is correct, but pressing caps lock won't cause the message to appear until the extension is supported.

Comment 4 Adam Tkac 2009-10-08 14:54:08 UTC
(In reply to comment #3)
> The problem here is that Xvnc does not support the Xkb extension, therefore
> XkbGetState is returning the state variable we gave it unmodified, which just
> so happens to have a 1 in the right slot.  I can make it so we clear this
> variable out before calling XkbGetState so the lack of a caps lock message is
> correct, but pressing caps lock won't cause the message to appear until the
> extension is supported.  

Actually in the VNC world (RFB protocol, to be precise) there is no CapsLock. RFB protocol states no CapsLock key can be sent from viewer to server. When you press CapsLock on the client followed by a key client only sends "X11 keysym" to the server (there are different keysyms for lower and upper cases). Thus "CapsLock is on" doesn't make sence on the server side at all in the vnc case.

Comment 5 Adam Tkac 2009-10-08 14:56:05 UTC
Adding anaconda-maint-list to CC. Check my comment #4, please.

Comment 6 Adam Tkac 2010-01-22 09:16:24 UTC
Fixed in tigervnc-1.0.90-0.1.20100115svn3945.el6. In this version Xvnc finally supports XKB and no warning is printed.


Note You need to log in before you can comment on or make changes to this bug.