Bug 525450 - RFE: Unable to set layout toggle key from keyboard settings dialog
Summary: RFE: Unable to set layout toggle key from keyboard settings dialog
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-settings
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 13:20 UTC by Alexey Torkhov
Modified: 2009-10-30 00:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-30 00:15:11 UTC


Attachments (Terms of Use)

Description Alexey Torkhov 2009-09-24 13:20:11 UTC
Description of problem:
There is no settings to set layout toggle key in keyboard settings. So, even if it is possible to add other layouts, it is not possible to switch them.

Version-Release number of selected component (if applicable):
xfce4-settings-4.6.1-4.fc12.x86_64

Comment 1 Vladimir Benes 2009-09-24 13:42:25 UTC
it is possible.. you have to install xfce4-xkb-plugin closing as NOTABUG

Comment 2 Alexey Torkhov 2009-09-24 14:17:32 UTC
But xfce4-keyboard-settings still won't allow to do the change? If so, it is bug (or, rather a rfe) for xfce4-settings.

Comment 3 Alexey Torkhov 2009-09-24 15:10:17 UTC
Checked xfce4-xkb-plugin - yeah, it allows to do change, but then layout changing "feature" of xfce4-keyboard-settings is just bringing confusion to users (like me :) - it has different settings dialog than xkb-plugin and lacks of this (essential) feature.
Reopening.

Comment 4 Christoph Wickert 2009-10-11 10:03:26 UTC
(In reply to comment #0)
> Description of problem:
> There is no settings to set layout toggle key in keyboard settings. So, even if
> it is possible to add other layouts, it is not possible to switch them.

Why do you assume there is a toggle key?

Changing keyboard layouts is not supposed to be done with a keyboard shortcut but by selecting the layout in the settings dialog. If you need to change the layouts on the fly, please use xfce4-xkb-plugin.

If you really think such functionality should be implemented in xfce4-keyboard-settings, file a feature request at bugzilla.xfce.org. Usually we maintainers take over this part, but I cannot convince somebody of a feature if I'm not convinced myself.

IMHO this is not a bug.

Comment 5 Alexey Torkhov 2009-10-11 17:19:55 UTC
(In reply to comment #4)
> (In reply to comment #0)
> > Description of problem:
> > There is no settings to set layout toggle key in keyboard settings. So, even if
> > it is possible to add other layouts, it is not possible to switch them.
> 
> Why do you assume there is a toggle key?

Because when multiply layouts are used - it is the easiest way to switch between them.

And multiply layouts is very common use case where main layout does not contain latin characters. I need them to type this bug report, for example :) At the same time I want to chat with my friends in some other language :)

> Changing keyboard layouts is not supposed to be done with a keyboard shortcut
> but by selecting the layout in the settings dialog. If you need to change the
> layouts on the fly, please use xfce4-xkb-plugin.

XFCE is not i18n-friendly in this way (and even english-centric) - xfce4-xkb-plugin is "optional" in default @XFCE install.

> If you really think such functionality should be implemented in
> xfce4-keyboard-settings, file a feature request at bugzilla.xfce.org. Usually
> we maintainers take over this part, but I cannot convince somebody of a feature
> if I'm not convinced myself.

I'll better convince you :)

Comment 6 Christoph Wickert 2009-10-11 20:11:07 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Why do you assume there is a toggle key?
> 
> Because when multiply layouts are used - it is the easiest way to switch
> between them.

Agreed, but you are supposed to switch the layouts by selecting them from the list.

> And multiply layouts is very common use case where main layout does not contain
> latin characters. I need them to type this bug report, for example :) At the
> same time I want to chat with my friends in some other language :)

Then you will need the xkb-plugin anyway, because it offers different keyboard layouts for different applications/windows.

> XFCE is not i18n-friendly in this way (and even english-centric) -
> xfce4-xkb-plugin is "optional" in default @XFCE install.

The first should be discussed with upstream and not with the Fedora maintainers. The latter is because the xkb-plugin 
- is not needed for most of our users and
- is buggy
- and not well maintained by upstream

> > If you really think such functionality should be implemented in
> > xfce4-keyboard-settings, file a feature request at bugzilla.xfce.org. Usually
> > we maintainers take over this part, but I cannot convince somebody of a feature
> > if I'm not convinced myself.
> 
> I'll better convince you :)  

Nice try ;) Nevertheless feature requests should be tracked upstream. It is unlikely that people interested will find this discussion here. If you file a request at bugzilla.xfce.org, you might have more people joining the discussion and supporting your POV.

Comment 7 Alexey Torkhov 2009-10-11 20:29:16 UTC
(In reply to comment #6)
> Nice try ;) Nevertheless feature requests should be tracked upstream. It is
> unlikely that people interested will find this discussion here. If you file a
> request at bugzilla.xfce.org, you might have more people joining the discussion
> and supporting your POV.  

Sorry, I'm not interested to talk with this upstream, as I'm not using it in daily live. Leaving bug as RFE until XFCE in Fedora will get more interested users out of non-english world.

Comment 8 Christoph Wickert 2009-10-30 00:15:11 UTC
I also live in the non-english world, but as explained several times before I'm convinced that RFE's should be filed in upstream's bug tracker. Fedora has a strict policy of following upstream instead of forking, so there is nothing we could do here without the Xfce developers.

If you are not interested in bringing this upstream, please don't complain if I close this report again. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.