Bug 525458 - windows exe inside packages
Summary: windows exe inside packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mono
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 13:44 UTC by Sergei LITVINENKO
Modified: 2009-09-24 18:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 17:01:49 UTC


Attachments (Terms of Use)

Description Sergei LITVINENKO 2009-09-24 13:44:59 UTC
Description of problem:
Unenspected windows executables inside package of linux distributive

/usr/lib/mono/1.0/setreg.exe                              
/usr/lib/mono/1.0/gacutil.exe
/usr/lib/mono/1.0/wsdl.exe
/usr/lib/mono/1.0/mcs.exe
/usr/lib/mono/1.0/mono-service.exe
/usr/lib/mono/1.0/certmgr.exe
/usr/lib/mono/1.0/sn.exe
/usr/lib/mono/1.0/xsd.exe
/usr/lib/mono/1.0/mod.exe
/usr/lib/mono/1.0/soapsuds.exe
/usr/lib/mono/1.0/chktrust.exe
/usr/lib/mono/1.0/disco.exe
/usr/lib/mono/1.0/mozroots.exe
/usr/lib/mono/2.0/gacutil.exe
/usr/lib/mono/2.0/mconfig.exe
/usr/lib/mono/2.0/wsdl.exe
/usr/lib/mono/2.0/mono-service.exe
/usr/lib/mono/2.0/gmcs.exe
/usr/lib/mono/2.0/xsd.exe
/usr/lib/mono/2.0/mdoc.exe
/usr/lib/mono/2.0/sqlsharp.exe
/usr/lib/mono/2.0/csharp.exe
/usr/lib/mono/2.0/httpcfg.exe
/usr/lib/mono/mono-addins/mautil.exe
/usr/lib/mono/gac/mono-service/1.0.5000.0__0738eb9f132ed756/mono-service.exe
/usr/lib/mono/gac/mono-service/2.0.0.0__0738eb9f132ed756/mono-service.exe

[root@fedora12a ~]# rpm -qf `cat aa` | sort | uniq
mono-addins-0.4-8.20091702svn127062.1.fc12.i686
mono-core-2.4.2.3-2.fc12.i686
mono-data-2.4.2.3-2.fc12.i686
monodoc-2.4.2.3-2.fc12.i686
mono-extras-2.4.2.3-2.fc12.i686
mono-web-2.4.2.3-2.fc12.i686


Version-Release number of selected component (if applicable):
mono-addins-0.4-8.20091702svn127062.1.fc12.i686
mono-core-2.4.2.3-2.fc12.i686
mono-data-2.4.2.3-2.fc12.i686
monodoc-2.4.2.3-2.fc12.i686
mono-extras-2.4.2.3-2.fc12.i686
mono-web-2.4.2.3-2.fc12.i686

How reproducible:
100%

Steps to Reproduce:
1. find / -name \*.[Ee][Xx][Ee]
2.
3.
  
Actual results:
Windows executable files are present

Expected results:
No any windows executable

Additional info:

/usr/lib/f-spot/f-spot.exe
/usr/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
/usr/lib/python2.6/distutils/command/wininst-7.1.exe
/usr/lib/python2.6/distutils/command/wininst-6.0.exe
/usr/lib/python2.6/distutils/command/wininst-8.0.exe
/usr/lib/python2.6/distutils/command/wininst-9.0-amd64.exe
/usr/lib/python2.6/distutils/command/wininst-9.0.exe

Comment 1 Paul F. Johnson 2009-09-24 17:01:49 UTC
This is not a bug - these are .NET binaries created by mono during the build process and are usually run through a script (for example gac-util.exe is called using gacutil which itself is run though the mono runtime).

Comment 2 Sergei LITVINENKO 2009-09-24 18:57:13 UTC
Thanks a lot for information.
Mono is already deleted from all my systems.


Note You need to log in before you can comment on or make changes to this bug.