Bug 52551 - Installing older packages is not allowed (only new)
Installing older packages is not allowed (only new)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 18:58 EDT by Dag Wieers
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 10:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2001-08-24 18:58:01 EDT
Description of Problem:
You cannot install an old package next to an existing package, only newer
package can be installed. Supplying --oldpackage is not allowed when
installing (which is weird in se) so one has to use --force (which is able
to overwrite existing files so that's not really what you want either).


Version-Release number of selected component (if applicable):


How Reproducible: Every time


Steps to Reproduce:
1. Install a newer kernel-package (let's say 2.4.3-12)
2. Then type: rpm -ihv kernel-2.2.19-20.i386.rpm
It won't work as you have a newer kernel installed.
3. So you will try: rpm -ihv --oldpacke kernel-2.2.19-20.i386.rpm
But that doesn't work either, as you may not supply --oldpackage
4. Finally you're obliged to use --force although you might not 
want to have --replacefiles --replacepkgs

And the man-page says --force is the same as --replacefiles --replacepkgs
and --oldpackage which is clearly NOT true.


Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeff Johnson 2001-08-25 09:36:50 EDT
Works for me.

bash$ sudo rpm -i kernel-2.4.2-2.i686.rpm 
package kernel-2.4.6-3.1 (which is newer than kernel-2.4.2-2) is already
installed
bash$ sudo rpm -i kernel-2.4.2-2.i686.rpm --oldpackage
bash$ rpm -q rpm
rpm-4.0.3-0.93
Comment 2 Dag Wieers 2001-08-26 10:41:38 EDT
[root@horsea /etc]# rpm -q kernel
kernel-2.4.3-12
[root@horsea /etc]# rpm -ihv kernel-2.2.19-7.0.8.i686.rpm --oldpackage
rpm: --oldpackage may only be used during upgrades
[root@horsea /etc]# rpm -q kernel
kernel-2.4.3-12
[root@horsea /etc]# rpm -ihv kernel-2.2.19-7.0.8.i686.rpm
Preparing...                ########################################### [100%]
package kernel-2.4.3-12 (which is newer than kernel-2.2.19-7.0.8) is already
installed
[root@horsea /etc]# rpm -ihv kernel-2.2.19-7.0.8.i686.rpm --oldpackage
rpm: --oldpackage may only be used during upgrades
[root@horsea /etc]# rpm --version
RPM version 4.0.2
Comment 3 Dag Wieers 2001-08-26 10:47:03 EDT
Ok, sorry.
Your statement was this was fixed in the latest unstable release.
The way you described it seemed that it wasn't a bug in Red Hat 7.1,
only after posting a comment that was clear to me. Thanks again.

Note You need to log in before you can comment on or make changes to this bug.