Bug 525513 - CMAN rpm install does not include magma/magma-plugins
Summary: CMAN rpm install does not include magma/magma-plugins
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 16:59 UTC by Jeffrey Needham
Modified: 2016-04-26 16:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-29 14:15:01 UTC


Attachments (Terms of Use)

Description Jeffrey Needham 2009-09-24 16:59:58 UTC
Description of problem:
When install CMAN, it forgets to include magma/magma-plugins, which are required to communicate with CCSD.

Version-Release number of selected component (if applicable):
cman-1.0.27-1.el4

How reproducible:
rpm install ccsd and cman and then start up cman with a simple cluster.conf file.   CMAN cannot contact CCSD without magma/magma-plugins

Steps to Reproduce:
1.
2.
3.
  
Actual results:
cman cannot contact CCSD

Expected results:


Additional info:

Comment 1 Lon Hohberger 2010-01-21 22:12:04 UTC
cman has an explicit 'requires' on ccs
ccs has an explicit 'requires' on magma

However, there is no installation dependency on magma-plugins containted with the RPMs themselves.  This is very deliberate and is done because it would lead to a circular dependency loop during both build-time and installation.

Here is the build dependency:

    +--------------+
    v              |
  cman   gulm <-+  |
  |  |   |  |   |  |
  |  v   v  |   |  |
  |  magma <--- magma-plugins  
  v   ^     |
 ccs -+     |
  ^         |
  +---------+

This leads to a required build order like this (for these packages):

  magma
  ccs
  cman | gulm
  magma-plugins

Run-time dependencies looks like this on the surface:

  cman   gulm
    +--+--+
       |
       v
      ccs
       |
       v
     magma

Once you install magma-plugins, the run-time dependencies look like this:

  cman   gulm
  ^ +--+--+ ^
  |    |    |
  |    v    |
  |   ccs   |
  |    |    |
  |    v    |
  |  magma  |
  |    |    |
  |    v    |
 magma-plugins

Magma is an automatic cluster switch API.  It is a bit like Linux's VFS layer, but for cluster software.  It goes through plugins trying to connect to the running cluster infrastructure based on the installed plugins if any exist.  If there are none, it returns failures to the calling application(s) when they try to connect to the cluster infrastructure using the magma calls.

Cman and gulm require configuration information, which is provided and managed by ccsd.  Ccsd requires things from the cluster infrastructure, notably membership and quorum states.

However, requiring the installation of 'magma-plugins' from 'ccs', 'cman', or 'gulm' would introduce a dependency loop.


I believe ccsd produces the following error if magma-plugins is not installed:

  Failed to connect to cluster manager.
  Hint: Magma plugins are not in the right spot.


Appropriate package selection for Red Hat GFS 6.1 is documented here:

https://www.redhat.com/docs/manuals/csgfs/browse/rh-gfs-en/ch-install.html#S3-PKG-SELECT-DETERM

It notes that 'magma-plugins' is required whether utilizing gulm or dlm as the locking layer for GFS.


Note You need to log in before you can comment on or make changes to this bug.