Bug 525555 - ACL Enhancement to support queue limit policies
Summary: ACL Enhancement to support queue limit policies
Keywords:
Status: CLOSED DUPLICATE of bug 523794
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 1.1.6
Hardware: All
OS: Linux
high
medium
Target Milestone: 1.2
: ---
Assignee: Rajith Attapattu
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 20:06 UTC by Rajith Attapattu
Modified: 2009-10-06 17:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 21:18:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rajith Attapattu 2009-09-24 20:06:31 UTC
Description of problem:

Need to add three new properties to the "create queue" rule: limitpolicy, maxqueuesize and maxqueuecount. The policy test can be implemented using existing code, but the numeric limits require a less-than-or-equal test. I.e. if a value for maxqueuesize is specified in the ACL file, an exception will be thrown if a value greater than this is specified in declareQueue. A value less than or equal would be acceptable. If maxqueuecount and/or maxqueuesize were omitted from the rule or specified as zero, the corresponding check would interpret the value as "unlimited".

Version-Release number of selected component (if applicable):

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
Currently you cannot specify ACL using these properties

Expected results:
Should be able to use the above properties for queue create ACL.

Additional info:
N/A

Comment 1 Mike Cressman 2009-09-24 21:18:27 UTC

*** This bug has been marked as a duplicate of bug 523794 ***


Note You need to log in before you can comment on or make changes to this bug.