Bug 52558 - mem= kernel parameter forces root fs as ext2
mem= kernel parameter forces root fs as ext2
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: grub (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 23:01 EDT by Ed McKenzie
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 11:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf (524 bytes, text/plain)
2001-08-25 12:20 EDT, Ed McKenzie
no flags Details
dmesg (6.83 KB, text/plain)
2001-08-25 12:20 EDT, Ed McKenzie
no flags Details
/proc/modules (715 bytes, text/plain)
2001-08-25 12:21 EDT, Ed McKenzie
no flags Details
/proc/modules (691 bytes, text/plain)
2001-08-25 12:23 EDT, Ed McKenzie
no flags Details
dmesg (6.55 KB, text/plain)
2001-08-25 12:23 EDT, Ed McKenzie
no flags Details
/proc/mounts (228 bytes, text/plain)
2001-08-25 12:24 EDT, Ed McKenzie
no flags Details
/proc/mounts (228 bytes, text/plain)
2001-08-25 12:25 EDT, Ed McKenzie
no flags Details
dmesg, mem=384M (6.70 KB, text/plain)
2001-08-25 12:35 EDT, Ed McKenzie
no flags Details

  None (edit)
Description Ed McKenzie 2001-08-24 23:01:06 EDT
Specifying a mem=XXX parameter to an ext3-enabled kernel results in the
kernel mounting the root fs as ext2.  This occurs only if XXX < actual RAM
installed.

I didn't see any odd errors in dmesg, and it appears jbd and ext3 loaded
successfully.  I suspect this is a kernel bug, since 1.) I checked that
grub is passing the right parameters, and 2.) initrd is definitely trying
to mount / as ext3.
Comment 1 Arjan van de Ven 2001-08-25 05:45:06 EDT
does dmesg say ANYTHING about initrd's ?
Comment 2 Stephen Tweedie 2001-08-25 05:49:53 EDT
Tried it, tested it both on modular and non-modular ext3, and it works fine. 
That was using LILO, though.

How do you know that initrd is trying to mount as ext3?  If there's any log
message about that being attempted and failed, could you please add that to this
report.  Thanks.
Comment 3 Ed McKenzie 2001-08-25 12:19:21 EDT
Hm, strange.  It seems jbd and ext3 aren't being loaded before rc; in fact, it
seems initrd isn't being loaded at all.  I don't get why, as grub is booting the
same config in both cases; I'm just adding 'mem=256M' by hand from the boot
screen.  This may be a grub bug.

I've attached all pertinent logs.
Comment 4 Ed McKenzie 2001-08-25 12:20:02 EDT
Created attachment 29494 [details]
grub.conf
Comment 5 Ed McKenzie 2001-08-25 12:20:56 EDT
Created attachment 29495 [details]
dmesg
Comment 6 Ed McKenzie 2001-08-25 12:21:44 EDT
Created attachment 29496 [details]
/proc/modules
Comment 7 Ed McKenzie 2001-08-25 12:23:13 EDT
Created attachment 29497 [details]
/proc/modules
Comment 8 Ed McKenzie 2001-08-25 12:23:49 EDT
Created attachment 29498 [details]
dmesg
Comment 9 Ed McKenzie 2001-08-25 12:24:26 EDT
Created attachment 29499 [details]
/proc/mounts
Comment 10 Ed McKenzie 2001-08-25 12:25:04 EDT
Created attachment 29500 [details]
/proc/mounts
Comment 11 Ed McKenzie 2001-08-25 12:27:00 EDT
The attachments with a -mem prefix are the output when mem=256M is passed on the
command line.  The others have no prefix, though in my testing mem=384M didn't
break anything (machine has 384MB of RAM.)
Comment 12 Ed McKenzie 2001-08-25 12:35:23 EDT
Created attachment 29501 [details]
dmesg, mem=384M
Comment 13 Ed McKenzie 2001-08-25 12:38:16 EDT
My previous comment made no sense.  Take two:

logs with -mem were the result of booting with mem=256M on the commandline. 
logs with -nomem were plain boots with no mem= line.  mem=384M doesn't seem to
break initrd.
Comment 14 Arjan van de Ven 2001-08-25 13:54:37 EDT
Looks like grub loads the image outside of the memory the kernel can see
due to the mem=xxx.
That would be (sort of) of a grub bug
Comment 15 Ed McKenzie 2001-09-19 11:58:03 EDT
Still broken in 0.90-10
Comment 16 Jeremy Katz 2002-01-25 21:43:28 EST
Fixed in 0.91-2 (if you want to use it on a 7.2-ish system, it should rebuild
cleanly)

Note You need to log in before you can comment on or make changes to this bug.