Bug 525600 - gnome-panel should explicitly require gnome-panel-libs
Summary: gnome-panel should explicitly require gnome-panel-libs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 525366 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 02:08 UTC by Michel Alexandre Salim
Modified: 2009-10-19 18:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-19 18:51:38 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2009-09-25 02:08:06 UTC
Description of problem:
gnome-panel currently has an automatically determined dependency on gnome-panel-libs; however, this does not guarantee that both are upgraded at the same time.

Per packaging guideline,

http://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package

perhaps in this case gnome-panel should have

Require: %{name}-libs = %{version}-%{release}

Version-Release number of selected component (if applicable):
$ rpm -q gnome-panel{,-libs}
gnome-panel-2.28.0-1.fc12.x86_64
gnome-panel-libs-2.28.0-1.fc12.x86_64


How reproducible:
Always

Steps to Reproduce:
1. rpm -q --requires gnome-panel | grep gnome-panel-libs
  
Actual results:
None

Expected results:
should require gnome-panel-libs with the same V-R

Additional info:

Comment 1 Ray Strode [halfline] 2009-10-19 18:49:43 UTC
*** Bug 525366 has been marked as a duplicate of this bug. ***

Comment 2 Ray Strode [halfline] 2009-10-19 18:51:38 UTC
dep added, thanks.


Note You need to log in before you can comment on or make changes to this bug.