Bug 525642 - No left-click menu when I run gnome-power-manager applet in xfce4
Summary: No left-click menu when I run gnome-power-manager applet in xfce4
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager
Version: rawhide
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2009-09-25 07:59 UTC by Tomas Pelka
Modified: 2009-09-25 12:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-09-25 12:55:49 UTC
Type: ---

Attachments (Terms of Use)

Description Tomas Pelka 2009-09-25 07:59:47 UTC
Description of problem:
when I'm using gnome-power-manager applet in xfce4, no left-click menu is diplayed. There is only right-click menu (Preferences/About/Help).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run Xfce with gnome-power-manager includet.
2. Left-click on displayed icon.
Actual results:
No menu appears.

Expected results:
Expected menu should be displayed.

Additional info:
Not sure if this is a bug or feature, also not sure if it is a gnome bug or xfce bug.

Comment 1 Richard Hughes 2009-09-25 09:31:31 UTC
What's the output of gnome-power-bugreport.sh ? Thanks.

Comment 2 Tomas Pelka 2009-09-25 10:03:19 UTC
Distro version:       Fedora release 11.91 (Rawhide)
Kernel version:       2.6.31-33.fc12.x86_64
g-p-m version:        2.28.0
HAL version:          0.5.13
System manufacturer:  missing
System version:       missing
System product:       missing
AC adapter present:   no
Battery present:      no
Laptop panel present: no
CPU scaling present:  no
Battery Information:
DeviceKit data:
  daemon-version:  011
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:   no
GNOME Power Manager Process Information:
tpelka    2116  0.0  0.5 313640 10544 ?        Ss   Sep24   0:02 gnome-power-manager
HAL Process Information:
68        1395  0.0  0.1  30152  3584 ?        Ss   Sep24   0:00 hald
root      1399  0.0  0.0  22156  1052 ?        S    Sep24   0:00  \_ hald-runner
root      1489  0.0  0.0  24272   956 ?        S    Sep24   0:00      \_ hald-addon-input: Listening on /dev/input/event4 /dev/input/event1 /dev/input/event0
root      1505  0.0  0.0  24268   996 ?        S    Sep24   0:02      \_ hald-addon-storage: polling /dev/sr0 (every 2 sec)
68        1507  0.0  0.0  21848   872 ?        S    Sep24   0:00      \_ hald-addon-acpi: listening on acpid socket /var/run/acpid.socket

Comment 3 Richard Hughes 2009-09-25 11:03:43 UTC
Right, you've got no battery devices to show. We don't display the suspend and hibernate icons by default anymore.

Comment 4 Tomas Pelka 2009-09-25 11:22:16 UTC
My description was obviously not clear. 

the thing is , that I set gnome-power-manager to display icon "always". So as in gnome I suppose that left-click raise menu which includes Preferences/About/Help (OK) and right-click raise other menu (sleep/hibernate or so). But second mentioned menu do not appear.

Hope this is more clear :)

Comment 5 Matthias Clasen 2009-09-25 12:49:37 UTC
The description at least clearly shows where you are wrong :-)

What happens in GNOME is that the left-click menu shows all detected batteries
and the right-click menus shows preferences/about/help. Therefore, no batteries => no left-click menu, even if the icon is shown.

Comment 6 Tomas Pelka 2009-09-25 12:55:49 UTC
I see it now, the menu was moved/removed in new gnome, therefore I was so confused. My bad, sorry guys. 

Closing as a NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.