Bug 525653 - Advertisement filters do not work as i expected
Summary: Advertisement filters do not work as i expected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: midori
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 08:39 UTC by Tomas Pelka
Modified: 2010-08-31 15:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-31 15:26:26 UTC


Attachments (Terms of Use)

Description Tomas Pelka 2009-09-25 08:39:57 UTC
Description of problem:
Do not get purpose of this, see "Actual results".

Version-Release number of selected component (if applicable):
100%

How reproducible:
midori-0.1.10-1.fc12.x86_64

Steps to Reproduce:
1. Run Midori.
2. Tools-> Configure Adverticement filters
3. Click Add button
  
Actual results:
Just nothing happend, new line is addet but no name, not editable. 

Expected results:


Additional info:

Comment 1 Bug Zapper 2009-11-16 12:54:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Christoph Wickert 2010-03-21 01:17:31 UTC
The line is supposed to have a URL of a filter. Even after adding an empty entry it is editable, at least in 0.2.2. Maybe the "Add" button should be greyed out if there is no content?

Comment 3 Kevin Fenzi 2010-08-28 22:24:11 UTC
midori-0.2.6-1.fc12 is the current version in f12 updates.
Can you update to this version and see if things work better? 

The ad filtering in 0.1.10 was primitive and didn't work too well... 

It should just work out of the box with newer midori versions.

Comment 4 Christoph Wickert 2010-08-28 22:54:40 UTC
Speaking of new versions. I have pushed 0.2.7 to F14 and devel, but not to any stable release because there are some changes in the UI that contradict a consistent user experience. See http://foo-projects.org/pipermail/xfce/2010-August/027480.html for more info.

Comment 5 Tomas Pelka 2010-08-30 09:06:05 UTC
Have fc13 now, since in midori-0.2.6-1.fc13 is no more Tools-> Configure Adverticement filters cant confirm.

Not sure when I get chance to install and verify on fc12.

Sorry

Comment 6 Kevin Fenzi 2010-08-30 15:26:34 UTC
It's an extention. Go to Tools -> extensions -> advertisement filter and check that it's checked to load. The option should then appear.

Comment 7 Tomas Pelka 2010-08-31 07:24:15 UTC
Right, works for me, verified on midori-0.2.6-1.fc13.

Thanks

Comment 8 Kevin Fenzi 2010-08-31 15:26:26 UTC
Great. I am going to go ahead and close this now then... feel free to re-open or file a new bug if you spot anything further. ;) 

Thanks!


Note You need to log in before you can comment on or make changes to this bug.