Bug 525683 - setroubleshoot: SELinux is preventing /usr/bin/gdb "read" access on /home/andreas/.mozilla/plugins/libflashplayer.so.
Summary: setroubleshoot: SELinux is preventing /usr/bin/gdb "read" access on /home/and...
Keywords:
Status: CLOSED DUPLICATE of bug 526791
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:e0ed7e50259...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 09:45 UTC by andreasfrische+redhat
Modified: 2015-02-01 22:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 12:54:16 UTC


Attachments (Terms of Use)

Description andreasfrische+redhat 2009-09-25 09:45:56 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/bin/gdb "read" access on
/home/andreas/.mozilla/plugins/libflashplayer.so.

Detailed Description:

[gdb has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by gdb. It is not expected that this access is
required by gdb and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                unconfined_u:object_r:mozilla_home_t:s0
Target Objects                /home/andreas/.mozilla/plugins/libflashplayer.so [
                              file ]
Source                        gdb
Source Path                   /usr/bin/gdb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdb-6.8.91.20090921-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-33.fc12.x86_64
                              #1 SMP Thu Sep 17 15:40:43 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 24 Sep 2009 10:50:14 PM CEST
Last Seen                     Thu 24 Sep 2009 10:50:14 PM CEST
Local ID                      4e25b1ae-854b-4587-a92d-c3b638e8d9d1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253825414.170:36): avc:  denied  { read } for  pid=2192 comm="gdb" name="libflashplayer.so" dev=sda2 ino=58057 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:mozilla_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1253825414.170:36): avc:  denied  { open } for  pid=2192 comm="gdb" name="libflashplayer.so" dev=sda2 ino=58057 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:mozilla_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253825414.170:36): arch=c000003e syscall=2 success=yes exit=14 a0=2bfbc20 a1=0 a2=0 a3=1 items=0 ppid=1494 pid=2192 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm="gdb" exe="/usr/bin/gdb" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t mozilla_home_t:file { read open };

Comment 1 Daniel Novotny 2009-10-29 15:39:54 UTC
hello Andreas,
what were you doing when this happened?

Comment 2 andreasfrische+redhat 2009-10-29 16:51:29 UTC
iirc ( tha' s a big if; it' s more than a month)
 firefox had just crashed and abrt was trying to generate a backtrace.

Comment 3 Bug Zapper 2009-11-16 12:56:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Nikola Pajkovsky 2010-05-05 12:54:16 UTC

*** This bug has been marked as a duplicate of bug 526791 ***


Note You need to log in before you can comment on or make changes to this bug.