Bug 525779 - Anaconda installation errors for virtual guests
Summary: Anaconda installation errors for virtual guests
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 17:14 UTC by Gurhan Ozen
Modified: 2013-11-04 01:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-04 18:32:19 UTC


Attachments (Terms of Use)

Description Gurhan Ozen 2009-09-25 17:14:43 UTC
Description of problem:
  Not sure if this is an anaconda or virt-install problem. Trying to install guests in rawhide-20090921 fails with following error:

anaconda 12.26 exception report^M
Traceback (most recent call first):^M
  File "/usr/lib/anaconda/yuminstall.py", line 433, in configBaseURL^M
    if not self.anaconda.intf.enableNetwork():^M
  File "/usr/lib/anaconda/yuminstall.py", line 297, in __init__^M
    self.configBaseURL()^M
  File "/usr/lib/anaconda/yuminstall.py", line 1054, in doBackendSetup^M
    self.ayum = AnacondaYum(anaconda)^M
  File "/usr/lib/anaconda/backend.py", line 274, in doBackendSetup^M
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:^M
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep^M
    rc = stepFunc(self.anaconda)^M
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext^M
    self.moveStep()^M
  File "/usr/lib/anaconda/dispatch.py", line 226, in currentStep^M
    self.gotoNext()^M
  File "/usr/lib/anaconda/cmdline.py", line 137, in run^M
    (step, instance) = anaconda.dispatch.currentStep()^M
  File "/usr/bin/anaconda", line 981, in <module>^M
    anaconda.intf.run(anaconda)^M
AttributeError: InstallInterface instance has no attribute 'enableNetwork'^M
^M
install exited abnormally [1/1] ^M
you may safely reboot your system^M

# virsh net-list
Name                 State      Autostart
-----------------------------------------
default              active     yes   


Version-Release number of selected component (if applicable):
rawhide-20090921

How reproducible:
Everytime

Steps to Reproduce:
1.# /usr/sbin/virt-install --name i386_hvm_guest --mac 00:16:3E:51:26:A4 --cdrom /var/lib/libvirt/images/i386_hvm_guest.iso --nonsparse --hvm --file /var/lib/libvirt/images/i386_hvm_guest -s 10 --debug --extra-args ks=http://lab.rhts.bos.redhat.com/kickstarts/hosts/guest-81-38.rhts.bos.redhat.com/ks.cfg --prompt --accelerate --os-variant=virtio26  --noreboot 

I've tried to install with --nonetworks option as well, failed the same way.

Comment 1 Chris Lumens 2009-09-25 18:48:16 UTC
I've committed a patch that'll provide a stub enableNetwork method so you won't get a traceback.  However, that doesn't solve the problem of why you even got to this point.  Can you attach /tmp/anaconda.log to this bug report?

Comment 2 Gurhan Ozen 2009-09-25 20:12:39 UTC
(In reply to comment #1)
> I've committed a patch that'll provide a stub enableNetwork method so you won't
> get a traceback.  However, that doesn't solve the problem of why you even got
> to this point.  Can you attach /tmp/anaconda.log to this bug report?  

No I can't .  At least not anytime soon unless you have an easy way to grab it while installing guests.

When guests are installed over rhts, the anamon kicks in and sends those logs to rhts scheduler but keep in mind that this is a guest crashing before it can set up its networking so it's not able to send anything to rhts or anywhere else for that matter.

Comment 3 Chris Lumens 2009-09-29 13:41:25 UTC
If you've got the ability to set up a remote syslog service, you can pass syslog= to anaconda and at least grab the anaconda.log from when stage2 starts.  That may have something useful in it.

Comment 4 Gurhan Ozen 2009-10-05 22:05:45 UTC
I am closing this bug, because rawhide-20091005 host/guests installed without this error.

Comment 5 Bug Zapper 2009-11-16 12:57:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Vedran Miletić 2009-12-04 18:32:19 UTC
The VERIFIED, FAILS_QA and RELEASE_PENDING bug states are not used by Fedora (they are used in the RHEL process).

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.