Bug 525856 - Yum crashes when a debuginfo package is installed
Summary: Yum crashes when a debuginfo package is installed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 11:09 UTC by Eli Wapniarski
Modified: 2014-01-21 23:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 16:22:18 UTC


Attachments (Terms of Use)
Traceback after package-cleanup (100.38 KB, text/plain)
2009-09-27 06:25 UTC, Eli Wapniarski
no flags Details

Description Eli Wapniarski 2009-09-26 11:09:31 UTC
Hi recently, (and by accident) installed a debuginfo package on my F11 i386 machine. When I ran yum update I received the following error. When I noticed that yum was detecting 1 debuginfo package I uninstalled the package and everything seemed to work OK. The output of the crash follows.

It seems to be OK on my x86_64 machine.

One thing to note on my x86_64 machine I have 2Gig RAM
On my i386 machine I have 1/2 Gig RAM.

Traceback (most recent call last):                                                                                                                           
  File "/usr/bin/yum", line 29, in <module>                                                                                                                  
    yummain.user_main(sys.argv[1:], exit_code=True)                                                                                                          
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main                                                                                               
    errcode = main(args)                                                                                                                                     
  File "/usr/share/yum-cli/yummain.py", line 178, in main                                                                                                    
    result, resultmsgs = base.doCommands()                                                                                                                   
  File "/usr/share/yum-cli/cli.py", line 348, in doCommands                                                                                                  
    self._getTs(needTsRemove)                                                                                                                                
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 101, in _getTs                                                                               
    self._getTsInfo(remove_only)                                                                                                                             
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 112, in _getTsInfo                                                                           
    pkgSack = self.pkgSack                                                                                                                                   
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>                                                                             
    pkgSack = property(fget=lambda self: self._getSacks(),                                                                                                   
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 491, in _getSacks                                                                            
    self.repos.populateSack(which=repos)                                                                                                                     
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 232, in populateSack                                                                            
    self.doSetup()                                                                                                                                           
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup                                                                                  
    self.ayum.plugins.run('postreposetup')                                                                                                                   
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run                                                                                   
    func(conduitcls(self, self.base, conf, **kwargs))                                                                                                        
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 51, in postreposetup_hook                                                                       
    enable_debuginfo_repos(yb)                                                                                                                               
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 38, in enable_debuginfo_repos                                                                   
    yb.doRepoSetup(thisrepo=r.id)                                                                                                                            
  File "/usr/share/yum-cli/cli.py", line 130, in doRepoSetup                                                                                                 
    self._getSacks(thisrepo=thisrepo)                                                                                                                        
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 503, in _getSacks                                                                            
    self.plugins.run('exclude')                                                                                                                              
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run                                                                                   
    func(conduitcls(self, self.base, conf, **kwargs))                                                                                                        
  File "/usr/lib/yum-plugins/priorities.py", line 126, in exclude_hook                                                                                       
    repopkgs_archless = _pkglist_to_dict(conduit.getPackages(repo), repo.priority)                                                                           
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 584, in getPackages                                                                           
    return self._base.pkgSack.returnPackages(arg)                                                                                                            
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 397, in returnPackages                                                                    
    return self.sacks[repoid].returnPackages(patterns=patterns,                                                                                              
KeyError: 'fedora'

Comment 1 Eli Wapniarski 2009-09-27 06:25:43 UTC
Created attachment 362801 [details]
Traceback after package-cleanup

On further investigation, I ran package-cleanup --problems and once again python seemed to crash. The attachment contains the traceback produced

Comment 2 James Antill 2009-09-28 20:16:58 UTC
If you get the latest yum from updates-testing (going into updates today), and the latest yum-plugin-auto-update-debug-info from upstream:

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=blob;f=plugins/auto-update-debuginfo/auto-update-debuginfo.py;h=9fb1f15df27a38ca479ffb1c451b8f228a78b1d5;hb=4f64320f6c1e616f72a676d3415421a7f87262de


...it'll work again.

Comment 3 Eli Wapniarski 2009-09-29 06:12:02 UTC
yum update produces

Plugin "auto-update-debuginfo" doesn't specify required API version


Conitnuing to check

Comment 4 Eli Wapniarski 2009-09-29 06:15:45 UTC
yum update - works

package-cleanup --problems - works

Seems to be fixed


Note You need to log in before you can comment on or make changes to this bug.