This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 52586 - KDE Control Center -> Panel -> Extensions crashes
KDE Control Center -> Panel -> Extensions crashes
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kdeadmin (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 17:43 EDT by Samuli Kärkkäinen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 17:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Samuli Kärkkäinen 2001-08-25 17:43:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
Clicking on Extensions TAB of KDE's Control Panel page Panel causes a crash
due to SIGFPE. At least when running as root. Backtrace is as following:

(no debugging symbols found)...(no debugging symbols found)...
0x40e205b9 in __wait4 () from /lib/i686/libc.so.6
#0  0x40e205b9 in __wait4 () from /lib/i686/libc.so.6
#1  0x40e9afe4 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x405f4eb8 in KCrash::defaultCrashHandler () at eval.c:41
#3  <signal handler called>
#4  0x4104c12a in KStepStyle::scrollBarMetrics ()
   from /usr/lib/kstephighcolor.so
#5  0x40963e8d in QScrollBar::metrics () from /usr/lib/qt-2.3.1/lib/libqt.so.2

#6  0x40963e3b in QScrollBar::sliderMinMax ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#7  0x40963f08 in QScrollBar::rangeValueToSliderPos ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#8  0x40963dc5 in QScrollBar::positionSliderFromValue ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#9  0x409632ac in QScrollBar::rangeChange ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#10 0x40962bb2 in QRangeControl::setRange ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#11 0x4096505b in QScrollView::updateScrollBars ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#12 0x40968a77 in QScrollView::resizeContents ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#13 0x40925ab7 in QListView::updateGeometries ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#14 0x409258da in QListView::show () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#15 0x408d2f26 in QWidget::show () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#16 0x4099476d in QWidgetStack::raiseWidget ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#17 0x4099436e in QWidgetStack::raiseWidget ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#18 0x4097b80e in QTabWidget::showTab () from /usr/lib/qt-2.3.1/lib/libqt.so.2

#19 0x4088ca81 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#20 0x409cc3e6 in QTabBar::selected () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#21 0x40979978 in QTabBar::setCurrentTab ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#22 0x40979720 in QTabBar::mousePressEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#23 0x408d3d51 in QWidget::event () from /usr/lib/qt-2.3.1/lib/libqt.so.2

#24 0x4083c6b1 in QApplication::notify () from /usr/lib/qt-2.3.1/lib/libqt.so.2

#25 0x4055ccc9 in KApplication::notify () at eval.c:41
#26 0x4080ab7f in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#27 0x40808068 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#28 0x4080703a in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#29 0x4083e56c in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#30 0x40806fb7 in QApplication::exec () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#31 0x4101ac58 in main () from /usr/lib/kde2/kcontrol.so
#32 0x0804d0c4 in strcpy ()
#33 0x0804dca9 in strcpy ()
#34 0x0804e136 in strcpy ()
#35 0x0804f501 in strcpy ()
#36 0x40d827c7 in __libc_start_main (main=0x804ef70 <strcpy+16888>, argc=2, 
    ubp_av=0xbffffca4, init=0x804a4d0 <_init>, fini=0x804fc60 <_fini>, 
    rtld_fini=0x4000db74 <_dl_fini>, stack_end=0xbffffc9c)
    at ../sysdeps/generic/libc-start.c:129


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a KDE session as root
2. Open KDE Control Center
3. Click on Look and Feel
4. Click on Panel
5. Click on Extensions

	

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-08-27 09:06:29 EDT
Can't reproduce this in 2.2-7, assuming fixed.

Note You need to log in before you can comment on or make changes to this bug.