Bug 525883 - computer does not resume from suspend from fedora 11 and open source ati radeon drivers
Summary: computer does not resume from suspend from fedora 11 and open source ati rade...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 17:03 UTC by Jason Grunhut
Modified: 2018-04-11 14:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-06 14:00:41 UTC


Attachments (Terms of Use)
Xorg.log (34.72 KB, text/plain)
2009-10-13 14:42 UTC, Jason Grunhut
no flags Details
Xorg.conf (742 bytes, text/plain)
2009-10-13 14:43 UTC, Jason Grunhut
no flags Details
dmesg (34.72 KB, text/plain)
2009-10-13 14:43 UTC, Jason Grunhut
no flags Details
Xorg.0.log (62.01 KB, text/plain)
2009-10-16 01:56 UTC, Jason Grunhut
no flags Details

Description Jason Grunhut 2009-09-26 17:03:33 UTC
Description of problem:
Dell laptop (Inspiron 6400, with ATI X1400 discrete video card) will not resume from standby (suspend-to-ram). Computer will turn on, but is unresponsive and only a garbled image (alternating static white/grey lines) is displayed. A full reboot is necessary by cycling the power.

Version-Release number of selected component (if applicable): Fedora 11, fully updated as of Sept. 24, 2009 including xorg-x11-server-Xorg-1.6.4-0.1.fc11.i586.rpm, Kernel 2.6.30.5-43.fc11.i586, xorg-x11-drv-ati-6.12.2-14.fc11.i586.rpm.

How reproducible: Problem existed before most recent xserver update but was intermittent and rarely occurred. After the most recent update, the problem exists each and every time the computer is suspended.

Steps to Reproduce:
1. Put computer to sleep using pm-suspend or via gnome-power-manager (set up to sleep on lid close and on power button)
2. Press power button to resume or open the lid

  
Actual results:
Computer is unusable, with garbled image displayed.

Expected results:
Computer resumes correctly and is usable.

Additional info: I've tried disabling KMS (using the nomodeset kernel option) but problem still exists. I've also tried using pm-suspend --quirk-none but still no luck. I've tried enabling/disabling the network and wireless card via the network manager applet before the computer is put to sleep, but this doesn't seem to make a difference either.

Comment 1 Jason Grunhut 2009-09-26 17:04:13 UTC
I forgot to mention that desktop effects is not enabled.

Comment 2 Matěj Cepl 2009-10-12 17:06:57 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Jason Grunhut 2009-10-13 14:42:29 UTC
Created attachment 364598 [details]
Xorg.log

Comment 4 Jason Grunhut 2009-10-13 14:43:30 UTC
Created attachment 364600 [details]
Xorg.conf

Comment 5 Jason Grunhut 2009-10-13 14:43:51 UTC
Created attachment 364601 [details]
dmesg

Comment 6 Matěj Cepl 2009-10-16 00:41:47 UTC
(In reply to comment #3)
> Created an attachment (id=364598) [details]
> Xorg.log  

Could we actually get /var/log/Xorg.0.log please? This is dmesg output as well.

Comment 7 Jason Grunhut 2009-10-16 01:56:23 UTC
Created attachment 364996 [details]
Xorg.0.log

Comment 8 Jérôme Glisse 2009-10-19 08:39:33 UTC
Can you test the fedora 12 live cd:
http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

To check that this doesn't work with it neither. I think this bug is a duplicate of :
https://bugzilla.redhat.com/show_bug.cgi?id=527874

Comment 9 Matěj Cepl 2009-11-05 18:38:27 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 10 Jason Grunhut 2009-11-06 13:05:00 UTC
Firstly, I sincerely apologize since I thought that I posted this comment several weeks ago. I believe that I found the cause, which isn't necessarily related to the video drivers. Somehow the service netplugd got enabled and as soon as I disabled this, everything worked fine again.

Even with all the newest kernel updates things still work (I haven't re-enabled netplugd though). As per your request, I have also just recently tried the Fedora 12 livecd and still am having the same success.

Again, my apologies.
Jason

Comment 11 Jérôme Glisse 2009-11-06 14:00:41 UTC
I am closing this bug, reopen a bug if you still have an issue with netplugd in fedora 12 (open it against netplugd or networkmanager).


Note You need to log in before you can comment on or make changes to this bug.