Bug 525888 - traceback : up2date with option --exclude
Summary: traceback : up2date with option --exclude
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.8
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 500798
TreeView+ depends on / blocked
 
Reported: 2009-09-26 17:39 UTC by Petr Sklenar ⛄
Modified: 2010-10-26 11:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-03 08:17:29 UTC


Attachments (Terms of Use)

Description Petr Sklenar ⛄ 2009-09-26 17:39:18 UTC
Description of problem:
run up2date with option --exclude

Version-Release number of selected component (if applicable):

up2date-4.8.1-33.el4
rhnlib-2.1.4-7.el4
distro : rhel4U8

How reproducible:
always

Steps to Reproduce:
1. up2date -uf --exclude=xml-commons

  
Actual results:
traceback

[root@dell-pe-sc1435-02 newsat]# up2date --exclude=xml-commons
An error has occurred:
exceptions.TypeError
See /var/log/up2date for more information
[root@dell-pe-sc1435-02 newsat]# tail -n 50 /var/log/up2date

[Sat Sep 26 13:31:34 2009] up2date logging into up2date server
[Sat Sep 26 13:31:35 2009] up2date successfully retrieved authentication token from up2date server
[Sat Sep 26 13:31:35 2009] up2date Updating package profile
[Sat Sep 26 13:31:39 2009] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Sat Sep 26 13:31:49 2009] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Sat Sep 26 13:32:06 2009] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[root@dell-pe-sc1435-02 newsat]# 


Expected results:
it should exclude pck and update whole system

Additional info:

Comment 6 Petr Sklenar ⛄ 2010-03-19 09:28:58 UTC
hello,
this bug is not fixed I could reproduce it as follow:

up2date -u:
xml-commons-resolver12                  1.3.03              5jpp_1rh            noarch
xmlsec1                                 1.2.6               3.1                 x86_64
xmlsec1-openssl                         1.2.6               3.1                 
x86_64
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
xml-commons-resolver10-1.3.03-5jpp_1rh   requires xml-commons = 0:1.3.03-5jpp_1rh 
xml-commons-resolver11-1.3.03-5jpp_1rh   requires xml-commons = 0:1.3.03-5jpp_1rh 
xml-commons-resolver12-1.3.03-5jpp_1rh   requires xml-commons = 0:1.3.03-5jpp_1rh 


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

.live.[root@hp-dl320g5-01 tps]# up2date --exclude=xml-commons-resolver10 -u
An error has occurred:
exceptions.TypeError
See /var/log/up2date for more information

.live.[root@hp-dl320g5-01 tps]# tail   /var/log/up2date
[Fri Mar 19 05:24:50 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Fri Mar 19 05:24:53 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

.live.[root@hp-dl320g5-01 tps]# rpm -q up2date rhnlib
up2date-4.8.1-33.el4_8.1
rhnlib-2.1.4-14.el4_8

Comment 7 Jan Hutař 2010-03-19 09:34:01 UTC
Maybe we should solve this as a whole, and rename the bug to "config parser should be more robust and should not expect ';' at the end of values" or something like this.

Comment 8 Miroslav Suchý 2010-04-23 15:22:22 UTC
I could not reproduce it. 
I run up2date -i --exclude rhnlib and got no TB. Can you please be specific or close it? Thx.

Comment 9 Petr Sklenar ⛄ 2010-04-26 12:02:11 UTC
it happens when machine has satellite channel:

trying with activated satellite530 on rhel48:

.qa.[root@rhndev4 ~]# up2date --exclude=xml-commons-resolver10 -u
An error has occurred:
exceptions.TypeError
See /var/log/up2date for more information
.qa.[root@rhndev4 ~]# tail -n 20 /var/log/up2date
[Mon Apr 26 08:00:15 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Mon Apr 26 08:00:40 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Mon Apr 26 08:01:05 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

[Mon Apr 26 08:01:48 2010] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 382, in main
    cfg['pkgSkipList'] = cfg['pkgSkipList'] + options.exclude

.qa.[root@rhndev4 ~]# rpm -q up2date rhnlib
up2date-4.8.1-33.el4_8.1.s390x
rhnlib-2.1.4-14.el4_8.noarch
.qa.[root@rhndev4 ~]# rpm -q xml-commons
xml-commons-1.3.03-7jpp.ep1.3.noarch
.qa.[root@rhndev4 ~]# hostname
rhndev4.s390.bos.redhat.com

Comment 11 Jan Hutař 2010-04-30 08:56:10 UTC
You have to set "pkgSkipList=" (with missing ";" at the end).

Comment 13 Jan Pazdziora 2010-07-26 15:32:19 UTC
Taking.

Comment 14 Jan Pazdziora 2010-07-26 15:35:29 UTC
We had this exact bugzilla open back in 2008, bug 456657. It was closed as NOTABUT in 2009.

If it was not see worthy of fixing back then, it's even less material for RHEL 4.9. Plus there are no ITs aligned to this bug.

I propose to NOTABUG.

Subhendu, Cliff, is that OK to override the blocker flag?

Comment 16 Jan Pazdziora 2010-08-03 08:17:29 UTC
As there haven't been complaints about the proposal to NOTABUG this bugzilla, closing as such.


Note You need to log in before you can comment on or make changes to this bug.