Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 52593 - mozilla exits abnormally
mozilla exits abnormally
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 20:54 EDT by Marty Shannon
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 20:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marty Shannon 2001-08-25 20:54:21 EDT
Description of Problem:
mozilla exits abnormally with the following diagnostics:

Gtk-WARNING **: invalid class type `(unknown)' in cast to `GtkObject'
Gtk-CRITICAL **: file gtkobject.c: line 1101 (gtk_object_remove_data):
assertion `GTK_IS_OBJECT (object)' failed.
Gtk-WARNING **: invalid class type `(unknown)' in cast to `GtkObject'
Gtk-CRITICAL **: file gtkobject.c: line 1101 (gtk_object_remove_data):
assertion `GTK_IS_OBJECT (object)' failed.
Gtk-WARNING **: invalid class type `(unknown)' in cast to `GtkObject'
Gtk-CRITICAL **: file gtkobject.c: line 1101 (gtk_object_remove_data):
assertion `GTK_IS_OBJECT (object)' failed.

It typically does this after hitting "reload" after being idle for some
time (like 1-15 minutes or so).

Version-Release number of selected component (if applicable):

kdebindings-kmozilla-2.2-2
mozilla-mail-0.9.2-10
mozilla-psm-0.9.2-10
mozilla-chat-0.9.2-10
nautilus-mozilla-1.0.4-34
mozilla-0.9.2-10
mozilla-devel-0.9.2-10

How Reproducible:
can't seem to force it reliably, but seems to be about 80%

Steps to Reproduce:
1. start mozilla (from an xterm)
2. let it idle for 10-15 minutes
3. hit "reload"

Actual Results:
abnormal termination

Expected Results:
a reloaded page

Additional Information:
Comment 1 Christopher Blizzard 2002-01-25 15:35:14 EST
Should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.